[SOLVED] M.2 Drive Not Recognized as Bootable After CPU Upgrade

Cypher7

Honorable
May 7, 2014
19
0
10,520
2
MSI x570 Creation motherboard, latest BIOS 1C3.

Windows 10 installed on ADATA XPG SX8200 Pro 1TB M.2, second ADATA XPG SX8200 Pro 1TB M.2 installed for storage.

Had a Ryzen 3900X installed previously, everything worked fine. Upgraded CPU to 5900X. Nothing else changed. After CPU upgrade Windows will not boot, I can only boot straight into BIOS. Under the BIOS boot selection, no drives are visible to select as the boot drive.

Seems that with the new CPU all BIOS settings were reverted to default. Is there a setting I need to change so that the M.2 with Windows becomes visible and I can boot from it?

Any other troubleshooting ideas? Thanks!
 

Mr.Spock

Respectable
Dec 8, 2019
1,133
133
1,890
114
you may need to boot in legacy mode as the UEFI setting may be locked to your old processor. then the drive may show, I'd also check the bios version to make sure it completely supports the 5xxx processor.
 
Reactions: Cypher7

Mr.Spock

Respectable
Dec 8, 2019
1,133
133
1,890
114
you may need to boot in legacy mode as the UEFI setting may be locked to your old processor. then the drive may show, I'd also check the bios version to make sure it completely supports the 5xxx processor.
 
Reactions: Cypher7

Cypher7

Honorable
May 7, 2014
19
0
10,520
2
you may need to boot in legacy mode as the UEFI setting may be locked to your old processor. then the drive may show, I'd also check the bios version to make sure it completely supports the 5xxx processor.
Thanks for the idea. In the BIOS there is an option for "Boot mode select" and UEFI is selected. This option is grayed out and I can't change it. Boot options only list UEFI Hard Disk and other UEFI options, nothing else. Any idea how to select legacy boot?

The motherboard and this BIOS version is claimed to support Ryzen 5000 by MSI.
 

Cypher7

Honorable
May 7, 2014
19
0
10,520
2
Found the answer here - set Settings\Advanced\Windows OS Configuration\BIOS UEFI/CSM Mode = [CSM]. Then I can select Legacy+UEFI.

That worked. Now I can boot into Windows! Thanks @Mr.Spock !

Am I now stuck in legacy boot mode or is there a way I can make UEFI work with the new CPU?
 

ASK THE COMMUNITY

TRENDING THREADS