Question M.2 drive not visible on Asus X570 ?

crooked windows

Distinguished
Jul 4, 2013
183
0
18,690
3
Just installed 8.1 onto an Asus x570. Wishing to run OS from M.2 drive and not having the M.2 drive visible is the problem I wish to solve. Any help would be greatly appreciated, thanks
 

Lutfij

Titan
Moderator
Make sure you're on the latest BIOS version on your motherboard. You're also advised to stick to the latest OS when installing an OS on concurrent hardware. Speaking of which, what is the make and model of your M.2 drive and which slot are you populating on the board with said drive?

Please include/list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
OS:

Asus X570 doesn't help narrow down which board you're using. It only tells us that brand of the board and the chipset you're on.
 

crooked windows

Distinguished
Jul 4, 2013
183
0
18,690
3
OK, so after a lost of digging it is possible to inject the drivers pinched from an older BIOS using RUFUS or alike (latest BIOS packages all drivers into one download so needs butchering to extract individual drivers, too messy for my skills) with 95% luck. He says only problem is little niggles with Graphics or sound during gaming and this drove the author of that posting to acknowledge defeat and install 10. Theres even windows 7 and one person running XP on a RYZEN but hes probably BSing or into the black arts of ZEN. So it is possible if your into a bit of programming.
So MS finally get me, but only for this gaming PC.
 

crooked windows

Distinguished
Jul 4, 2013
183
0
18,690
3
Make sure you're on the latest BIOS version on your motherboard. You're also advised to stick to the latest OS when installing an OS on concurrent hardware. Speaking of which, what is the make and model of your M.2 drive and which slot are you populating on the board with said drive?

Please include/list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
OS:

Asus X570 doesn't help narrow down which board you're using. It only tells us that brand of the board and the chipset you're on.
Hi Lutfij specs:

Ryzen 5 3600
asus X570 gaming-E
OS 8.1 pro
Crucial P5 1TB NVMe in slot 2 (1 or 2 is OK)
RAM 16 GB Crucial sport 3000 LT

Just had a copy of windows 8 pro and thought I would have ago at seeing if this would work and it does. Gaming is great (so far) but not getting use from the M.2 P5 1TB drive, it's the only reason I just thru on win 10 to get my moneys worth.

Still interested in putting win 8 onto a build soon so any suggestions that works would be appreciated. It will mean finding an older board somewhere in great working condition :) but if theres a link to the magic install, sweet.

(Linus S. tested XP, 7, 8.1 and 10 and 8.1 is king for gaming. All the others had background stuff pulling them down.)
thanks
 

ASK THE COMMUNITY

TRENDING THREADS