M.2 Drive on X470 Aorus Ultra Gaming MOBO

Jan 2, 2019
1
0
10
0
So, I've got hopefully an easy-to-fix issue here, but I can't find any accurately relating posts/information anywhere on the web..so here I am..



I just purchased my very first M.2 drive online, and it arrived today, I put the drive into the First M.2 slot on the x470 mobo and booted my system.



And bam, the drive doesn't show up in my File Explorer, under my Partition creator or any other programs used to view/create partitions.



So I powered down, and swapped the drive to the lower, second M.2 slot and tried booting again, but same thing.

The drive is just not showing up.



I checked my x470 MOBO manual, and it does state that the M2B_SOCKET (the lower, second M.2 slot) is for PCIe SSDs only, and the M2A_SOCKET, the first M.2 Slot supports SATA and PCIe SSDs but beyond that it offers no other explanations.



I tried checking my M.2 drive manufacturers website, to see if the M.2 Drive I purchased is SATA or PCIe, but I don't really see that information there or on neweggs site.



But really my question is, am I doing something wrong? Is there something I need to enable in the x470 bios? Or any other ideas that anyone can think of? I've only ever used HHDs and this is my first SSD experience so..



Here are links to the Newegg and Manufacturers website for the M.2 drive, as well as a link to information about my motherboard if needed:

M.2 Drive:

https://www.nemixram.com/nemix-ram-ssd-512gb-m-2-2280-6gb-s-3d-nand-tlc-internal-solid-state-drive.html

https://www.newegg.com/Product/Product.aspx?Item=9SIA7S68DS7286



X470 MOBO:

https://www.gigabyte.com/Motherboard/X470-AORUS-ULTRA-GAMING-rev-10#sp
 

Dark Lord of Tech

Speedy Gonzales
Moderator
With that M2 SATA, which is no faster than a standard SATA SSD , you can use either one , but I would use:
1 x M.2 connector (Socket 3, M key, type 2242/2260/2280 PCIe 2.0 x4/x2 SSD support) (M2B_SOCKET)

I would get a NVME SSD in the future, like a Samsung 970 EVO or Pro in the future and use this slot for top performance , but it will disable a couple of SATA ports.
1 x M.2 connector (Socket 3, M key, type 2242/2260/2280/22110 SATA and PCIe 3.0 x4/x2* SSD support) (M2A_SOCKET)

https://mygaming.co.za/news/hardware/118533-different-types-of-ssds-explained-sata-vs-m-2-vs-pcie.html
[video="https://www.youtube.com/watch?v=kx0ynC8Thlw"][/video]
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS