Question M.2 not being detected

AndyDalis

Distinguished
May 3, 2015
94
0
18,630
0
I have an M.2 I pulled from one of my laptops that I wanted to remove files from. I have an EVGA z370 Classified K motherboard so I have 2 M+B key M.2 slots. One of them is occupied by my OS, a Samsung 970 EVO. So I put the new M.2 into the slot under my 2080 graphic card. However, I don't see it in the BOIS or Disk Managment. Am I doing something wrong? It has no restrictions according to the manual and I was using anti-static equipment to move it. I have checked the installation and it is seated correctly

Current Config
  • Top M.2 E-Key: Empty
  • Middle M.2: HP 834166-001 <- This one isnt being detected
  • Bottom M.2: 970 EVO

  • PCIe 1: Empty
  • PCIe 2: Empty
  • PCIe 3: Empty
  • PCIe 4: 2080 GPU
  • PCIe 5: Wifi card
  • PCIe 6: Disabled
  • SATA 0: Disabled
  • SATA 1: 950 EVO (Documents)
  • SATA 2: Archive Drive
  • SATA 3: VM Drive
  • SATA 4: Hot Plug bay
  • SATA 5: Empty
Part List: https://pcpartpicker.com/list/38M2w6
 
Last edited:

Lutfij

Titan
Moderator
What BIOS version are you on for your motherboard? To also add, why didn't you wipe the drive while it was in the laptop? You might want to also pass on the full specs to your build that you're trying to work with said M.2 drive. Make and model of the M.2 drive?
 

AndyDalis

Distinguished
May 3, 2015
94
0
18,630
0
What BIOS version are you on for your motherboard? To also add, why didn't you wipe the drive while it was in the laptop? You might want to also pass on the full specs to your build that you're trying to work with said M.2 drive. Make and model of the M.2 drive?
BIOS version from msinfo: 1.14 2019
I don't want to wipe it. I want to transfer files over to my main rig and then maybe wipe it. The laptop I'm pulling it from has a badly damaged wifi card and antennas as well as it missing most of its case screws.
M.2 make and model: HP 834166-001 - 128GB SATA III 6Gb/s TLC NAND M.2 NGFF (2280) Solid State Drive

Specs from Pcpartpicker: https://pcpartpicker.com/list/38M2w6
 
Last edited:
BIOS version from msinfo: 1.14 2019
I don't want to wipe it. I want to transfer files over to my main rig and then maybe wipe it. The laptop I'm pulling it from has a badly damaged wifi card and antennas as well as it missing most of its case screws.
M.2 make and model: HP 834166-001 - 128GB SATA III 6Gb/s TLC NAND M.2 NGFF (2280) Solid State Drive
There is something about the bottom m.2 shares lanes with sata 1 and you need to disable it in the bios.
 

AndyDalis

Distinguished
May 3, 2015
94
0
18,630
0
There is something about the bottom M.2 shares lanes with SATA 1 and you need to disable it in the bios.
It is actually SATA 0 for that one

Here's how I have my storage configured

Top M.2 E-Key: Empty
Middle M.2: HP M.2
Bottom M.2: 970 EVO

SATA 0: Disabled
SATA 1: 950 EVO (Documents)
SATA 2: Archive Drive
SATA 3: VM Drive
SATA 4: Hot Plug bay
SATA 5: Empty
 

ASK THE COMMUNITY

TRENDING THREADS