Question m.2 not installing in GPT

Feb 28, 2019
10
0
10
0
Hey guys, just looking for any advice anyone can give me, I have been at this for awhile. Ok so I am attempting to install a clean version of Windows 10 Home with GPT on a Samsung Evo Plus 250gb m.2. I have tried everything I can think of to install this correctly however every time I do a new installation of Window 10 it always installs MBR format instead of GPT.

Some things I have done to attempt to correct the issue:
Ensured the Windows 10 Home version is x64 not x32
Converted my m.2 drive from GPT to MBR(by default this is already done, but I converted to MBR and converted it back to GPT in a attempt to fix the issue)
In my BIOS(UEFI) I disabled CSM and Safe Boot since from what I read this may cause an issue with GPT
I use RUFUS 3.4 to install the ISO downloaded from Microsoft, ensure its on NTFS file with GPT enabled

These are all the tips I read up on and have yet to be successful. Any advice would be appreciated.

System Overview:

Motherboard: Gigabyte z390 Aorus Master
Chipset: i9 9900k
M.2: Smasung 970 Evo Plus 250gb
CPU Cooler: Corsair h150i
Graphics Card: EVGA Geforce FTW 3 RTX 2080ti
RAM: Corsair Dominator 3200mhz 32gb
Operation System: Windows 10 Home x64
 
Last edited:

karenjoly

Respectable
Apr 13, 2018
1,329
19
1,815
166
The process you used needs improving. Try these steps:

Create an up to date USB install media by following the steps outlined here:
https://www.microsoft.com/en-ca/software-download/windows10
Then disconnect or disable all hdd /ssd drives but the one where you will install windows.

Insert the USB media tool, with the windows install files, into the board. Next startup and go to the board setup and ensure the board is configured to use UEFI boot settings, that CSM is enabled, leave safe boot alone, and ensure SATA mode set to AHCI.

On the motherboard boot device menu, select the command that identifies both the firmware mode and the device. For example, select UEFI: USB Drive or Windows Boot Manager: USB and list that device in the first boot slot on the board.
Reboot. Install begins.

When choosing an installation type, select Custom. On new disks, the drive will show a single area of unallocated space. If there are partitions, select each one and then "delete".

Select the unallocated space and click Next. Windows detects that the PC was booted into UEFI mode, partitions the drive using the GPT and begins the installation.

NOTE: Any data on the drive will be lost
 

talric79

Distinguished
Mar 6, 2011
7
0
18,510
0
Hey guys, just looking for any advice anyone can give me, I have been at this for awhile. Ok so I am attempting to install a clean version of Windows 10 Home with GPT on a Samsung Evo Plus 250gb m.2. I have tried everything I can think of to install this correctly however every time I do a new installation of Window 10 it always installs MBR format instead of GPT.

Some things I have done to attempt to correct the issue:
Ensured the Windows 10 Home version is x64 not x32
Converted my m.2 drive from GPT to MBR(by default this is already done, but I converted to MBR and converted it back to GPT in a attempt to fix the issue)
In my BIOS(UEFI) I disabled CSM and Safe Boot since from what I read this may cause an issue with GPT
I use RUFUS 3.4 to install the ISO downloaded from Microsoft, ensure its on NTFS file with GPT enabled

These are all the tips I read up on and have yet to be successful. Any advice would be appreciated.

System Overview:

Motherboard: Gigabyte z390 Aorus Master
Chipset: i9 9900k
M.2: Smasung 970 Evo Plus 250gb
CPU Cooler: Corsair h150i
Graphics Card: EVGA Geforce FTW 3 RTX 2080ti
RAM: Corsair Dominator 3200mhz 32gb
Operation System: Windows 10 Home x64
I went through the same problem last night, I was lucky and had a clean new drive, so I didn't have to save data. I went the option 2 route and cleared everything up.

https://www.diskgenius.com/how-to/the-selected-disk-has-an-mbr-partition-table.php

I did have an up-to-date USB windows 10 install though, you may want to track one down before you start.

Let me know if this works for ya.
 
Feb 28, 2019
10
0
10
0
Hey guys thanks again for all your help, so last night I went ahead and did what @karenjoly suggested and got some results. So in CSM i enabled bios to load in UEFI, also i found a USB option to turn off legacy and boot from UEFI so I did this. I did not find anywhere for ACHI im not sure if this would really even apply since my m.2 is directly connected to my motherboard. I made sure there were no other drivers connected during installation. I then when ahead and installed from USB and something weird happen. As i was doing a clean install after completely whipping the m.2 before hand of any partitions, after it installed with no issue it seem to create two different boot ups on my m.2 one in GPT and one for MBR. So to test it i went ahead and disabled anything else to boot except the GPT but it would still force boot into MBR even after i disabled the MBR in boot options. So thats kind of where I am at, Im sure I am missing something in the bios thats preventing me from installing the GPT correctly. Any thoughts would be great.

Thanks again.
 

karenjoly

Respectable
Apr 13, 2018
1,329
19
1,815
166
I do not understand what you mean by the following

it seem to create two different boot ups on my m.2 one in GPT and one for MBR.


Explain how you know this ? If you are looking at disk management, please provide a screen cap.

A couple of changes might help/ First, understand that MBR and GPT are partition modes. A drive can be subject to one or the other. A disk must be GPT to support uefi and if the drive is MBR then an uefi board can boot it only so long as there is a subsection of uefi called legacy or CSM enabled. So engage csm and in
Storage Boot Option Control select
UEFI Enables UEFI option ROM only. (Default)

Second, leave usb alone, set it back to default.

Reinstall ensuring only the m 2 is installed and deleting all partitions.
 
Feb 28, 2019
10
0
10
0
See thats whats confusing to me, I have to drive set at GPT during installation(ensured this by pulling diskpart and then disk list to verify GPT) however when i installed it seems to have set up a MBR and also a GPT. Im assuming its a GPT because when i pull up my BIOS after the install it shows in the boot area two diffrent options on the same m.2 drive. One option is the MBR Samsung Evo 970 Plus and the other option is just Samsung Evo 970 plus.
 

karenjoly

Respectable
Apr 13, 2018
1,329
19
1,815
166
A bootable drive will have Windows Boot manager or UEFI as part of the drive label just like the lower drive you now have. Put it in the top position. The drive labeled without the prefix will not boot and can be ignored except to avoid selecting it when manually chosing a boot drive if you have occasion to do so down the road.

Boot away.
 
Feb 28, 2019
10
0
10
0
Yah it boots just fine I just can't seem to figure out how to get the drive to be in gpt instead of mbr at the end of the day it's not a big deal just frustrating lol
 

karenjoly

Respectable
Apr 13, 2018
1,329
19
1,815
166
Yes boot away.

For some reason I suspect you are actually curious why the samsung is listed twice, once with the WBM prefix and once without. In windows 10, the WBM prefix is only attached to UEFI bootable disks and the disk labeled with the bare disk description, without the UEFI prefix, denotes a disk bootable only under a legacy bios. If you go to the CSM switch in your bios, I think you will see the you have engaged it and set it for legacy + UEFI. To eliminate the non UEFI disk from the boot list, turn off CSM.
 
Mar 20, 2019
3
0
10
0
Hi i am also having similar problems, my comp wouldn't boot so i tried start up repair which didnt work.
I also didn't have a restore point but had alien-ware recovery software which i used and this has messed everything up.
My os was on ssd and i had 1t drive also, ssd was c and 1t was d
They have swapped around now ssd is d and 1t is c.
I have tried to reinstall windows with a usb and it will not install as it says its gpt petition.
I have tried booting in legacy and UefI.
I have tried bootrec /fixmbr which works, but bootrec /fixboot access denied.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS