M.2 Not Showing Up in Bios - Asus Strix B250F Gaming

Easton Scott

Honorable
Jan 5, 2013
4
0
10,510
0
Hey guys, first post I believe. I searched the forums before asking but nothing really applied to my particular motherboard. Apologies if this has already been solved.

My M.2 SSD is seated firmly and screwed right into place. My mobo has two M.2 slots and I believe mine is in the first slot. I have searched through bios for anything M.2 related with no success. I plan to boot from this M.2.
It does not appear in bootable devices.
Have any of you had experience with this board and know how to enable the M.2 as a bootable device? Thanks in advance guys!

M.2 - Samsung 960 Evo 256GB
Mobo - Asus Strix B250F Gaming
 

blazeaglory

Prominent
Aug 2, 2017
44
0
560
6
Fingers crossed this works for me!

I can install my m.2 drive and use it for a storage drive but so far i cannot use it for a boot drive or for cloning. EDIT: I finally figured out how to use the drive for my system files and everything loads in the blink of an eye. Just think all these years of upgrading RAM and CPU, all that was needed was a faster storage device.

I'm going to try this when i get home but why so much trouble? Why is Windows or my z97a not doing this automatically? Just a thought not trying to hijack the thread!
 
The background here is NVME SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver.

Guide for Windows 10 installation:

1- The M.2 drive has to be the only drive installed.

2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, not windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows 10 will now start installing to your NVMe drive as it has its own NVMe driver built in.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVMe drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode. (see #3 above)

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

I would also recommend installing the Samsung NVMe driver at this point to replace the Windows one. (optional)

 

Easton Scott

Honorable
Jan 5, 2013
4
0
10,510
0
Calvin7,

I followed your instructions exactly and when I load the Windows Installer from the Bootable USB (made with the official Microsoft tool) the installer does not detect the M.2 as a drive.
 

blazeaglory

Prominent
Aug 2, 2017
44
0
560
6
Fingers crossed this works for me!

I can install my m.2 drive and use it for a storage drive but so far i cannot use it for a boot drive or for cloning. EDIT: I finally figured out how to use the drive for my system files and everything loads in the blink of an eye. Just think all these years of upgrading RAM and CPU, all that was needed was a faster storage device.

I'm going to try this when i get home but why so much trouble? Why is Windows or my z97a not doing this automatically? Just a thought not trying to hijack the thread!
 

Easton Scott

Honorable
Jan 5, 2013
4
0
10,510
0
SOLVED:

Sorry for the late reply. You were a great help Calvin, however the final fix was moving the M.2 to the second M.2 slot.

From there I follow your previous instructions a second time and it worked!
 

ASK THE COMMUNITY

TRENDING THREADS