Question M.2 NVMe drive missing from BIOS ?

Jan 15, 2023
Hey everyone!
I recently build my grandparents a new PC as they were using an old HP prebuilt on windows 7 and ended up with multiple run-ins with malware and visits to PC-repair shops. They only used it to check the weather, send emails, and use office, but I built as best I could and utilised some Black Friday sales.

I’ve built my own pc and a off for my brother but I’m in no way an expert! But have never encountered an issue like this before.

specs are as follows:

Motherboard: Asus H610M-E Prime
CPU: Intel i3 12100 4.3GHz
RAM: Kingston 16GB (2x8GB) KF432C16BBK2/16 Fury Beast 3200MHz DDR4
Storage: Kingston 1TB NV2 2280 NVMe SSD
PSU: SilverStone 400W Strider Essential 80+ Power Supply

I installed windows 11 home and transferred all their personal files onto it and everything was going smoothly for about a month or so.
Then earlier this week, all of a sudden there was no boot to windows, going straight into bios. There are no bootable drives listed anywhere in the bios, and under the NVMe settings it says "no drive detected". I’ve looked through and ensured everything is set to UEFI and not legacy, secure boot enabled etc. I’ve updated the BIOS to the latest version and basically done everything possible that I could find online but nothing has worked! I’ve even tried installing a GPU and enabling CSM to see if that would change anything, but to no avail.

my main thought now is maybe there was a windows update that mucked around with device drivers and now there are no device drivers, thereby stopping it from being detected?

The only thing I haven’t tried is installing into my personal PC to see if:
  1. It’s recognised by my pc, and if not
  2. If I download drivers it is then recognised
Does anyone know where I can go from here? I’m at my wits end getting this fixed and am starting to think that maybe it’s bricked/just stopped working all of a sudden somehow.

Any suggestions or thoughts would Be greatly appreciated!
Jan 15, 2023
Yep nothing in my PC either, not in bios, device manager or drive management. Any ideas on where to go from here? Is it most likely the drive has just failed?


If the drive will not up in BIOS or Disk MGT on multiple machines, I would say the drive is dead. Check the drives warranty and RMA requirements.

Also a lot of times a chromebook can be good for grandparents and sticking just with the "app store".

Or don't give them admin rights, choose and ad blocker as well.