Question m.2 only gets detected after i plug in a flash drive, turn system on, shut down, take flash drive out, and boot.

omartazi2003

Reputable
Jan 27, 2019
3
0
4,510
0
I recently built my pc about a week ago, and everything worked perfectly until today. I installed all my games played just fine and then today i go to boot my pc up and it goes straight to the bios saying, "No bootable devices found" and no ssd detected in the m.2 category of the bios. I then try taking the drive out, reinstalling it; doesn't work. Try changing the m.2 to the other slot on my mobo; nothing changes. Try cleaning cmos with no solution. Updated bios to latest version same error. I then try to boot my pc on an empty flash drive, it tells me no operating system found which I expected so I just restarted the pc. Then at that point my pc just boots into windows just fine. I have a Crucial 1tb P3 pcie gen3 and a gigabyte aorus b550 pro ac mobo with a ryzen 5 5600x.
Any idea why this is happening?

Update: it just did it again. After successfully booting into windows, I posted this thread. I took the flashdrive out and shut down my pc. turned it back on again and boom straight to bios no bootable device found. I shut down and plugged the flashdrive in again. Botted and it says no operating system found please restart. I restarted and it boots into windows just fine again. what do i have to do to fix this
 

ASK THE COMMUNITY