Question M.2 Problem

bdikkal

Prominent
Dec 16, 2018
24
0
510
0
After i installed a 256gb m.2, my computer stopped seeing my 980gb samsung ssd drive. I removed m.2 but the ssd is not working anymore. When I use the same cable and the same port to connect an hdd instead of the ssd,it works. In case, i also connected the ssd to different ports with 2 different cables but still nothing. Its almostt like the m.2 killed my ssd for good! Any ideas?

MB is asus prime z390a
 

bdikkal

Prominent
Dec 16, 2018
24
0
510
0
A pcie m.2 device needs high bandwidth.
As a result some sata ports will be disabled.
Check your user manual and what you installed where.
Yeah i installed the ssd to a different alot than the one that is disabled. It didn't work. I alsi removed the m.2 and the ssd still won't work.
 

bdikkal

Prominent
Dec 16, 2018
24
0
510
0
Tried and sti
You may need to clear the cmos to reset your motherboard.
If your new m.2 is a samsung pcie device, install the samsung nvme drivers.
Download here:
Ll no goo
You may need to clear the cmos to reset your motherboard.
If your new m.2 is a samsung pcie device, install the samsung nvme drivers.
Download here:
Tried and still not working. This is weird. Thanks for the help tho mate.
 

bdikkal

Prominent
Dec 16, 2018
24
0
510
0
Did you install windows on the m.2 drive?
If so, and the 960gb sata drive was attached during the process, all sorts of problems can be generated.
No. Windows was installed on ssd. I got another m. 2 today. Installed windows on 1
All other drives (1 more m.2 and 3 hdd's) work but the ssd is still not working. I guess it really is dead.
 

bdikkal

Prominent
Dec 16, 2018
24
0
510
0
Did you install windows on the m.2 drive?
If so, and the 960gb sata drive was attached during the process, all sorts of problems can be generated.
Damn, soooo stupid. i dont know why i didnt try this before. Faulty power cable... All is well now.
 

ASK THE COMMUNITY