• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

M.2 SSD as boot disk question

Status
Not open for further replies.

The Original Ralph

Distinguished
i7-4790 (locked),
asus Z97M-PLUS
16 gb, GSkill 1600 MHz Ripjaws
2 samsung 840 evo SSDs 250 GB (one for OS and one for "worktable" for video files
1 WD 4 TB HDD for storage
1 samsung xp941 256 GB M.2 SSD
asus GTX 750 Ti 2 GB gpu

OS: Windows 7 Ultimate 64bit w/SP1 and fully updated


okay got my samsung xp941 M.2 SSD in. Installed it and set it as a GPT disk in computer storage management, as the bios is UEFI

used EaseUS ToDo Backup to clone the orig OS disk over to the M.2 disk. In Bios set M.2 for sata ports 5&6 in PCH Storage - everything else related to PCI is set to "auto". Set Bios to "default settings" using F5 and set the M.2 disk as the boot disk.


I could not get the computer to boot from the M.2 disk, no matter what i did.

Went back to computer>manage>storage management and noticed the orig disk that is booting is set as a MBR disk, so i wiped the M.2 disk, reformatted it, set it as a MBR disk, and cloned the OS disk to it again

still no love

The M.2 SSD is recognized, both as a GPT and a MBR disk, in "my computer".

the only other consideration or thought is the drive letters on the M.2 are not "C" & "D", so i disconnected the orig OS disk altogether, leaving only the M.2 with OS on it, and it would not boot, just go into BIOS

i don't get the feeling a fresh clean install of windows is going to make a difference .... or is it?
I just did a complete fresh install and full updates on the orig OS SSD one week ago, took about 12 hours so there is a reason i'm trying to avoid that.

any ideas?/

thanks in advance
 

The Original Ralph

Distinguished
yes it completed successfully, and in case you're not familiar with EaseUS, i've used it for about 5-6 years and never had an issue backing up a cloned disk back to the OS drive when it got invaded by a virus, malware etc. The clone was "sector by sector" and optimized for SSD

the source disk or original OS disk is 250 GB (samsung 840 EVO) and the M.2 is a 256 GB samsung xp941

i researched boot issues and found a number of similiar issues re failing to recognize as boot drive but none of the solutions apply here - all the issues seemed to be mobo specific - one other note, I'm running windows 7 ultimate 64x with SP1 and fully updated

in some of the solutions posted in other threads, posters indicated asus techs suggestion changing pch storage setting from ACHI to IDE, so i tried that, and got a bsod on boot after POST
tried disabling it altogether, same
tried changing the M.2 setting back to "Auto" hoping that might trigger it to booting - again, no love
 

The Original Ralph

Distinguished


yes samsung has "migration" software for their SSDs and yes, the M2 is set as the first boot device in boot priority, the optical drive set as 2nd and the original samsung 840 evo is set as 3rd

part of the issue i think, is that samsung has started selling the M.2 SSD or more specifically the xp941 as a retail unit, up until now it's been an OEM unit and there's no support that i could find on the samsung web for the M.2

i'm wondering, commonly in research i found that the UEFI BIOS requires the boot disk to be set as a GPT disk, but i never knew that and therefore never did it when i first installed the sammy 840 evo, and again, found it set as a MBR disk

any chance that tells you anything?

i keep going back and reading my posts and damn if it looks like english isn't my native language

 

The Original Ralph

Distinguished


one question before i retire - i'm still thinking the M.2 showing the OS partition as "A" instead of "C" might have something to do with it - wondering if i clone the OS disk from an external enclosure thru a USB 3.0 port to the M.2, if it won't clone the M.2 showing the OS partition as "C" and if that won't make my problem go away

any thoughts??

otherwise i'll go ahead and bite the bullet and do a fresh windows installation -

 

The Original Ralph

Distinguished
did the samsung migration backup - no love
so i went back and did another EaseUS clone to the M.2

did some more research and found a youtube instruction video on setting the M.2 SSD as boot drive and the poster was demonstrating on an ASUS ROG mobo, and interesting part, there's a selection in that BIOS that i don't have in my Z97M-Plus mobo under "Onboard Devices Configuration"



i'm going to back down to a couple of previous BIOS releases and see if i see it in those, otherwise i'll have to query ASUS Tech support

one other odd occurrence that i've noticed before this issue. In EaseUS backups, the cloned disk is an exact copy of the orig disk, so i can view the directory tree and open any file i choose, delete any file or add a file. For ease of knowing which disk was booting, on the M.2 after cloning i went to users>deskstop and deleted a word doc i'd left on the orig disk's desktop.

Twice it re-appeared on the M.2 disk after it was deleted. It's acting like the system is set to Raid even though it's set to ACHI, and i'd noticed this sometime back when i'd copy video files to one disk, i'd find it already on the 2nd hdd when i'd go to copy it there
 

The Original Ralph

Distinguished
for anyone researching using the Samsung xp941 M.2 SSD as a boot drive, i found what is apparently the issue that has been keeping mine from booting, even though it's recognized in BIOS, from RamCity's forum - they cloned their orig SSD to the xp941 using EaseUS, same as i had, and they apparently made the mistake i'm making - the original SSD had had windows installed from the DVD, and apparently you can't install windows in UEFI mode from DVD, it has to be from a USB drive

https://www.ramcity.com.au/blog/how-to-clone-an-existin...

"6. Potential XP941 Issues

If you are migrating from an old SSD/HDD to an XP941, you may get tripped up (like I did) with the partitioning scheme on your old drive.

For the clone to the Samsung XP941 to be successful, my testing so far has showed that the original drive must have an EFI partition, meaning it had Windows installed in UEFI mode from a USB drive, rather than in Legacy mode from a Windows DVD.

In the process of creating this tutorial I was attempting to clone an SSD with an MBR partitioning scheme to the Samsung XP941, and I was not able to boot from it, no matter which utility I used to attempt to repair it. You can see below my original source disk configuration, and that an EFI partition is absent:...."


and for anyone interested, a link to ramcity's "how to install windows to xp941"

spent 6+ hours between late last night and this morning and still no love
but have found another combination of BIOS settings specific to windows 7 installation, with something i wasn't doing as well, disconnecting all other drives - the two SSDs in my computer with MBR partitions may somehow be confusing the system - i have no idea at this point, but will try again later on

in case it helps someone researching this issue with their install, this is the newest combo of settings
http://www.tomshardware.com/answers/id-2451780/install-windows-samsung-ssd-xp941-asus-x99-deluxe.html - scroll down to the 2nd to last post
 

The Original Ralph

Distinguished
spent another 2-3 hours this afternoon, mainly discovering more of the mistakes i was making - i was leaving other hard drives connected, and finally found one set of directions where poster indicated dis-connected all other drives was real important, main reason windows wants to install the "C" drive and it will create one as long as there isn't already one in the system and 2nd reason, it frigging corrupted something in the boot files of the existing OS SSD, even though i hadn't selected those drives.

But i've gotten closer - i'm now at the point where it tries to install to M.2 drive partitioned as GPT but now i've hit the brick wall of windows asking for drivers that when i point it at a usb flash drive where they're installed, none are "signed" and it refuses them....wtf
 

The Original Ralph

Distinguished
i've read so many posts on using the 941 my eyes are about to bleed.

Just got off the phone with asus tech support and actually had called 3X - first time the individual was so negative in his attitude, i gathered it wouldn't work as he didn't want it to work so i ended that support call

2nd tech was an idiot - asked me for my memory, wanting both size and model, i read him the GSKill model , and he tells me that's why it wouldn't work - it's not on the QVL list - unfortunately for him there's no way to tell if it's on the QVL list as he would need the model # which he hadn't asked for and i'd only bought it after checking the QVL list. Told the guy this and i might as well have been talking to the moon

3rd support tech, sounded intelligent & knowledgeable and just said flat out "we do not support any SSD that does not come pre-installed OPROM" - which i can at least understand. problem is, as sammie only technically sells this as an OEM drive, they don't supply one pre-installed and right now have no intention of doing so.

At least AsRock has apparently written new BIOSs to handle this, as Asrock owners are not running into these problems.

so i've got to decide to either jump to an AsRock board or use this xp941 as a storage drive. It would be ideal for video editing so i might go that route
 

SMS2015

Reputable
Jul 21, 2015
1
0
4,510
0


Hi, I have same mobo but can not make samsung xp941 256 GB M.2 SSD bootable in EFI. I am able to add boot entry via EFI shell but after the reboot the disk description part changes in NVRAM for M.2 entry as if it would be physically disconnected during the boot.
Any other SSD or HDD entries stay so once I get to OS loader I can boot whatever OS is installed on either drive.

Are you using legacy or EFI boot? In legacy mode it takes 5 min for the mobo to report there is no boot loader on M2..

Serge

 

The Original Ralph

Distinguished
Ramcity has a pretty good set of installation guides for the various M.2s https://www.ramcity.com.au/view/installation-guides/installation - their guides use the "RUFUS" software to install windows onto a USB drive but iirc, it didn't mention the copy of windows has to be an ".iso" copy - i assumed rufus would put it into a ,iso file on it's own

if you go over to the asus mobo support forums https://vip.asus.com/forum/topic.aspx?elitepost=0&SLanguage=en-us&board_id=1&page_size=20&page=3&count=193900 and do a search for z97m-plus m.2 threads, you'll find installation guide to install directly from the windows dvd - the rufus approach is much quicker, don't know why, when installing from the windows dvd, it takes 60-75 minutes vs 6-8 minutes in rufus reading from the usb flash drive

hope that helps
 

Wollan

Reputable
Sep 5, 2015
1
0
4,510
0
This guide helped me install Win 7 on a SM951 (which was not originally bootable). My motherboard is a ASUS Maximus VIII Gene (Z170 / 1151) : https://rog.asus.com/forum/showthread.php?74678-How-to-boot-windows-from-you-m-2-SM-951-on-Asus-Maximuss-VIII-guide

My new PC only had USB 3.0 ports which makes Win 7 installation notoriously difficult / impossible.
In addition my m-ATX system didn't have a optical drive and a external usb optical drive wasn't able to be used for install...

I ended up temporary connecting a sata ODD and following the guide.
 

The Original Ralph

Distinguished
Just to wrap up, installation completed and been using the xp941 almost two months now and love it - definitely worth the effort.

Had one issue where i tried to eliminate an empty partition of 5.6 GB using easeUS Partition Manager and it caused the system to crash (BSOD) and then would not reboot. And windows DVD would not repair the corrupted boot files.

After i had gotten it working as OS drive, i had partitioned a backup SSD (840 EVO) as GPT, and cloned the xp941 to it to save as backup. When i went to clone the backup drive back to the xp941 (using EaseUS ToDo Backup) it cloned successfully, but would not boot, but this time the Windows repair attempt was successful.

There have been a number of posts indicating the M.2 PCIe SSDs do not perform any faster in day to day operations, and those stmts are made by a lot of folks that apparently are far more technically knowledgeable than i am. Unfortunately, i don't know what those posters are ignoring but my experience has been that my video rendering times have gone down to 35-40% of the times it used to take, rendering from a SSD to another SSD (both fairly new 840 EVO SSDs).

There was a fairly lengthy debate on this on another forum with me starting to wonder if i'd been smoking home rolls with my observing reduced times when two other posters popped up, both of whom who render video and reporting the same reduced times i was, with one just having installed his intel 750 and doing side by side comparisons rendering the same video file to/from sata SSDs and from a sata SSD to the intel 750. Link to that thread http://forums.anandtech.com/showthread.php?t=2441787&page=5

for those thinking about a M.2 PCie SSD it's definitely worth the effort, and in fact from what i've seen in the various forums the installation process is fairly simplified nowadays.

I'm now waiting for the SM950 PRO NVMe (that johnnylucky posted about yesterday) to release as i'm going to jump on one - i;m really curious what my times will drop to rendering to/from PCIe SSDs.
 

BlankReg

Commendable
Mar 17, 2016
4
0
1,510
0
My system: ASUS z170 Gaming Pro motherboard, Samsung 950 Pro m.2 NVMe PCIe drive, Windows 7 Pro

I just got my computer from iBuyPower. Hadn't even looked in the BIOS. Started doing Windows updates, and after one batch of them then reboot, I got a big red screen saying SECURE BOOT VIOLATION. Couldn't even find the drive.

Went into BIOS, changed boot from "Windows EUFI" to "Other OS" and it booted fine.

Hope that helps.
 

Derek_22

Commendable
Apr 12, 2016
4
0
1,520
1
Ok guys this is the reply I got from Asus. Board was never designed to work with the 950 Pro M2 drive. But watch this link .https://www.youtube.com/watch?v=No-ct8pQcIg&nohtml5=False
Further to that link Asus also recommend the following :
ERP Ready set on--------Enabled s4 +SS
this is found in------Bios-Adv-Apm Configursation
They also say best to do all this with a clean install.
Hope this helps. Dark_Comet
 

Paul Anderegg

Honorable
Aug 30, 2012
18
0
10,510
0
So how exactly do I get my MBR cloned 950 Pro to boot up Windows 7? I don't see any solutions, just people with my exact problem saying they got it working. I tried the fresh install path, and the computer was a wreck, unstable, unusable, I NEED to clone my old SSD MBR over to this. I used Samsung Migration utitility, and am on a Gene VIII MB.

I have been dealing with this damn evil non Windows 7 compatible MB and NVMe for 2 weeks, it;s going back to Newegg Monday if I can't get this solved today. Too much frustration for the $1000 in parts I bought.

Paul



 
Status
Not open for further replies.

Similar threads