Question M.2 SSD is randomly no longer bootable ?

cycle motion

Sep 15, 2019
My new cpu cooler came in and my computer was on windows 11 and working fine and I turn it off like normal so I can put the new cooler in and after I get it in I turn it back on and the m.2 is no longer available on the boot menu in bios. When I go to NVME config it’s listed there and it says 0gb and when I run the self test on it it’ll fail. It doesn’t show up on the front page of m2 tab on my bios either. CSM is off and secure boot is off. I tried putting csm to legacy as well and still nothing. I also tried disconnecting all the other hard drives as well and nothing. I get a separate ssd and install windows 10 and still nothing even in the windows 10 media install it’s not listed. Now I’m in windows 10 in device manager and I see it listed by its full name, I also see it listed in disk partition manager as unknown and not initialized at the bottom and it’s not showing up in file explorer either. I have no idea what to do now. It was working fine had it for about 2 years and now it doing some weird stuff. I also tried the other m.2 slots and the same thing happens, and I updated my bios as well.



Last edited:
Jan 16, 2023
When you installed the new cpu cooler, are you absolutely sure that you didn't touch the m.2 drive by accident? Even a small scratch in the wrong place can make it behave like this.

Also, carefully check the drive for any stray cpu paste, some cpu thermal paste products are conductive, so a very small amount of paste in the wrong place can also render a device unusable.

To check the drive, take it out of the motherboard and carefully examine it. If you have a magnifying glass, use it.

Some of the defects created like this can be fixed, but some can not. Good luck!