Question M.2 SSD not detected anymore

Sep 28, 2020
3
0
10
0
Specs:
Asus Prime x570-P Motherboard
AMD Ryzen 3700x
Msi GeForce RTX 2070 Ventus
2x 8GB Corsair Veng LPX DDR4 3200MHZ
Seagate 1TB Barracuda Hard drive, SATA III
Pny 500gb XLR8 CS3030 M.2 NVMe SSD, PCIe Gen3 x4


How the issue began. One night I turned off my computer from the 'Shut Down' bottom from the bottom left corner, went to bed only to find out 15mins later, that my computer still had not properly shut down. Monitor screen was black but all the hardware and computer's led lighting was on so I proceeded to close the system by holding the power key. Fast forward to next night, I try to open my computer only to find out that I was getting force booted to BIOS. After a while i realized my boot menu was empty. I have installed WIN10 on my M.2 drive

After changing some boot menu settings according to some information from online I was able to get my Hard Drive pop up, which I then proceeded to install the windows to see if the M.2 is seen in Disk Management (Bios says both M.2 Sockets are empty). The Drive was there at first showing it wasnt in use, but couldn't initialize it due to "Parameter Incorrect" with both GPT and MBR. Now the M.2 isnt visible in Disk Management either. I did not check it until today, but the NVME configuration tab does indeed show the drive there, but shows it holding 0GB of storage. I have updated bios to its latest version too but did not solve the problem.

What could be the issue?
 
I know that my 1tb nvme was acting up a few times but since I unplugged it and re-inserted the drive I have not had any issues with it maybe just try tacking out and re-installing it fixed my issues might be lucky.
 
Sep 28, 2020
3
0
10
0
I know that my 1tb nvme was acting up a few times but since I unplugged it and re-inserted the drive I have not had any issues with it maybe just try tacking out and re-installing it fixed my issues might be lucky.
Thanks for the response! I've tried re-insterting it to both of my sockets several times and wished i'd be lucky, like you in this case.. Also forgot to mention that i just tried to re-install windows from usb drive while my hard drive is disconnected and it recognizes the m.2 but says it has no storage in it. Could this mean its broken or what?
 

ASK THE COMMUNITY