Question M.2 SSD not showing up after a series of strange events ?

Dec 15, 2022
Model: Samsung 970 Pro 512gb (used for 3-4years)

Current issue: Drive not showing up anywhere after selecting "scan for hardware changes" in device manager. Now it shows 1GB unallocated space on the drive that cannot be initialized.

History: It was being used as the OS drive until yesterday. I was having freezes for almost 3 weeks at random times while playing games (worked fine outside of it).

The exact issue was the 100% active time on C (M.2) drive without any read/write (in task manager). The system would completely freeze but I would be able to hear my friends on discord and move the cursor. The only solution was to turn off power.
Initially, I thought it was hardware related so I downloaded Samsung Magician and checked every single drive (they all showed as good). Tried a few other apps but they didn't show any errors either.

Checked the ram, processor, and GPU separately but everything was working fine so I assumed the issue was with windows. To test it I did a new Windows 10 install on my secondary sata SSD and the games started working again.
*One thing of note, after installing windows on SATA SSD, I tried switching back to M.2 because it still had the old OS installed with a LOT of private files BUT it would not boot up from it. It showed up fine in the bios and I could access it normally via windows explorer but it simply wouldn't boot from it.

At this point the M.2 drive (now renamed F) was still perfectly fine. I moved a couple of games to C and kept the rest on the M.2 intending to move everything one by one later. Even played warzone 2 directly from it perfectly fine.

But earlier today I started the PC and when loading the game from M.2 drive (which still had its old OS installed, IDK if that matters) the game crashed. I tried to go into the folders and was given the "access denied" error whenever trying to access the F drive.

So I restarted a couple of times and it seemed like it was working fine for the first few minutes but after a bit it would start denying access again.

My fix: Tried to give myself access to it and it worked for the most. I could access program files (x86) and move a few games from there but when trying to go into "users" it would again deny access.

I thought it was a driver issue so installed latest drivers from the Samsung site and then went into the device manager and clicked on "scan for hardware changes". It disappeared from there and upon restarting it didn't show up at all.

Not in bios, not in Device manager, and certainly not in windows explorer.

Looks like this now, doesn't even show its proper name:

My concern right now is to get the data back. Losing the drive itself would certainly be a loss but I have almost 350gigs of very important work-related files on it.

I'm not THAT computer illiterate and didn't mess with anything that I didn't understand. Simply changing perms and scanning for hardware changes shouldn't have done this.
The numerous tests I ran on the drive mean that it still probably works and this is more of a software/incompatibility issue.

Would appreciate any help.


Win 11 Master
Jun 12, 2015
Sounds like it was on its way out and you should replace it.

if you still have proof of purchase you could rma it as its got a 5 year warranty =

its possible its gone now and you can't recover from it

Not in bios, not in Device manager, and certainly not in windows explorer.

Looks like this now, doesn't even show its proper name:
doesn't your screenshot show it in device manager?



Latest posts