• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question M.2 SSD suddenly not detected anymore

PrPrO

Distinguished
Feb 9, 2012
13
0
18,510
0
Hello hello,

I haven't used my PC for 4 months (no access due to COVID....) and then moved with it.
So when I started it the first day (before moving) it was working as it should. When I started it the second day it started freezing in windows after a couple of minutes, I've checked for updates later and seen it was updated the day before. So the problems began when Windows 10 decided it would be good to install a major update.

I somehow managed to boot from time to time and it would freeze again. I can't perform Windows reset or even rolling back the update (win says we cannot revert to previous build, etc...) and all my restore points were deleted.

I have tried booting the PC while the SSD is out of the slot and its works (boots), as son as I plug it into the SATA M.2 slot it won't boot anymore, just opens the BIOS instead of windows everytime I try to restart... I see the light is on on the SSD but it isn't detected in BIOS or in the Windows Installation process (I wanted to perform chkdsk via recovery options but it isn't detected). My BIOS has M2_1 and M2_2 in Disk info, but my drive isn't detected there...

I haven't changed anything in BIOS and it started ating up after the windows update, now I have flashed the BIOS to latest version but to no avail.
BIOS is currently in Leagcy/UEFI mode.
Is there something in BIOS I can do to at least detect it and perform the checks/install new windows?
I have no idea what to do anymore, except for taking the SSD somewhere who has an SATA M.2 slot to try if its not faulty.

EDIT: Forgott to mention it was in update installation pending loop. I tried eleting updates that caused problems, but it just updated again, even though I have disabled it. But atleast I could boot to Windows, and now the SSD isn't even detected.

I forgot to mentions that it booted from time to time before I flashed the BIOS, afterwards it doesn't even detect it.

Any help is appreciated.

System: Windows 10
MB: MSI B450 GAMING PRO CARBON AC ATX AM4
CPU: AMD Ryzen 5 2600
SSD in question: Crucial MX500 500 GB M.2-2280 SSD
GPU: Asus GeForce RTX 2070 8 GB STRIX GAMING
Parts: https://de.pcpartpicker.com/list/RBsjD2
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS