• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question M.2_1 slot on Maximus X Hero motherboard does not work

cerealizeable

Commendable
Mar 19, 2018
8
0
1,510
0
I recently bought a Samsung 970 EVO Plus SSD in order to have 2 SSDs on my motherboard, originally I have been using Samsung 960 Evo SSD (both are PCIe SSDs not SATA). The Samsung 960 EVO SSD was plugged into my M.2_2 slot and has been working fine for over a year. When I removed the heat sink cover and plugged the Samsung 970 EVO Plus into the M.2_1 slot, BIOS and Windows never recognize it. I have isolated the issue to the M.2_1 slot not working because:
  1. unplugged all harddrives from all 6 SATA ports (all are empty)
  2. Plug either SSD into M.2_2 slot and it is recognized
  3. Any SSD I plug into M.2_1 slot is not recognized.
Additionally, I have went into the BIOS > Advanced > Onboard Configurations > and:
  1. set M.2_1 slot to [Auto], and I've tried [PCIe only]
  2. set M.2_2 slot to [x2] and [x4]
BIOS doesn't recognize the device anywhere. Windows > Device Manager doesn't recognize the device. Even Samsung Magician, from the Samsung SSD driver site doesn't recognize any SSD inserted into the M.2_1 slot.


Is there something I am missing here? Originally I wasn't sure if the Maximus X Hero supports 2 M.2 SSDs. But considering I plugged in an M.2 SSD into the M.2_1 slot with no other drives plugged into any of the 6 SATA port and no SSD plugged into the M.2_2 slot AND still no drive was found, I think there is an issue with the motherboard recognizing the M.2_1 slot.
 

ASK THE COMMUNITY

TRENDING THREADS