Question m2 Drive only shows on first (hard) boot after motherboard swap?

Aug 12, 2021
1
0
10
0
All worked fine with the m2 but my USB drives weren't working, so I replaced the motherboard.

On the new motherboard, which is IDENTICAL to the last one, it only recognizes the m2 drive on a hard boot. If I ctrl + alt + dlt OR do any "save and exit" in bios OR "press any key to continue" I don't see it. The M2 is my boot drive.

On a hard boot, its in my boot menu AND its in my bios, but soft boot it is on neither. I've read much about these drives being finicky, so I tried all these steps from searching:

Cleared CMOS and changed settings to UEFI settings from legacy
Swapped between M2 ports (intel optane is other M2 device)
Used the same ports as the last motherboard
Tried to update firmware but samsung 970 firmware update says "no compatible drives found"
Tried to run windows boot repair but it either doesn't see the drive or reads it as "X" and therefore write protects it

Any other ideas? or is it dead? This isn't how a dead drive usually behaves since it works EVERY TIME I hard boot.

M2: Samsung Evo 970
Motherboard: ASRock Phantom Gaming 4

 
Last edited:

ASK THE COMMUNITY