Question M4A89GTD PRO/USB3 does not boot after ram change

Dec 27, 2019
1
0
10
0
Hi All,

Got myself into a trouble here.
Stuck for holidays @ relatives, wanted to play mmo, it was horribly slow
M4A89GTD PRO/USB3
Phenom II X4 955
4GB RAM: 2x 2GB G.SKILL DDR3-1333
A couple of old HDD
GTX260 896MB

Quite accidentally got new RAM 2x Kingston HyperX Fury 8GB DDR3-1600 (total 16GB) and decided to do an upgrade.
Queried about compatibility but the result was inconclusive as the board is old and the memory is newer. Decided "it could work".

Simply unplugged old and inserted new into same slots.
1. First switch - no beep (was beeping before), MemOK- solid red, does not start. Pressed MemOK - started blinking slowly, then faster and then solid again.

2. Left 1 stick closer to cpu - same result.

3. Removed battery for 20 min - same result.

4. Unplugged and held power button for 30 sec. MemOK light switched off. But still does not start. Pressed MemOK- started flashing slowly constantly.

5. Put old memory in. Same result as 4 !!

6. Repeated 1-4 with old memory. Nothing changed.

The system was pretty dusty. Now I dismantled it completely and do the cleaning. Will try to assemble again after I find some thermal paste/sticker.
But in general I'm worried I just wasted a slow but still good PC that I don't own :/

Any advice what else should I troubleshoot?

Thanks a lot for the help.
 

ASK THE COMMUNITY

TRENDING THREADS