Question Mac 10.11.6 "Your connection is not private" error for many websites

joeyd219

Commendable
Sep 12, 2017
4
0
1,510
0
On several very common websites (from Uhaul, to Columbia.edu, to Oscar Health Insurance), neither Google Chrome nor Safari will not load the website. Chrome gives this error:

Your connection is not private
Attackers might be trying to steal your information from www.uhaul.com (for example, passwords, messages, or credit cards).
NET::ERR_CERT_DATE_INVALID

When I click in the address bar, "not secure" > "certificate (invalid)", this is the error message:

*.uhaul.com
Issued by: COMODO RSA Domain Validation Secure Server CA
Expires: Sunday, November 1, 2020 at 6:59:59 PM Eastern Standard Time
This certificate has an invalid issuer

In Safari, it gives a similar error message:

"This website may be impersonating uhaul.com to steal your personal or financial information"

Troubleshooting steps I've tried so far:

1.) Running available Mac OS updates
2.) Resetting date and time
3.) Uninstalling and reinstalling Chrome
4.) Deleting all Chrome extensions
5.) Deleting all certificates from Keychain
6.) Installing Malwarebytes and running a scan (it didn't find anything)
7.) Turning firewall off
8.) Clearing Chrome cache/cookies


This is my home wifi network; other devices aren't having any issues. At this point, I'm not sure what it could be; I've tried every troubleshooting step out I can find. My only guess is that maybe it's some stubborn virus Malwarebytes didn't catch? I'm not super duper tech literate, so maybe there's something I'm not thinking of.

Thank you in advance so much for your help!!
 

COLGeek

Cybernaut
Moderator
Your OS is quite dated, so security updates (the lack thereof) are likely the issue. Another factor could be your system time, make sure your time (including timezone) is properly set.

What model Mac are you using?
 

ASK THE COMMUNITY

TRENDING THREADS