Macbook SSD A1425 not detected in Windows 10

Jan 1, 2019
1
0
10
0
I have a 128GB Sandisk SSD A1425 extracted from a dead Macbook Pro Retina model. This A1425 SSD comes with a 7+17 pin interface.
I need to recover some data from this SSD urgently. I have an HP Windows 10 laptop that I am using to do this.
1. The SSD is not detected in Windows explorer - nor it is listed in Disk Management tool.

a. The SSD is connected to a SSD to SATA adapter card custom built for A1425. (Item - IJARP SSD to SATA PCI M-Key Adapter Card for 2012 Apple MacBook Air A1398 A1425; Purchase Link -> https://www.amazon.in/gp/product/B07L11JL7J/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1)
Unable to confirm whether the combination in #a works fine but the LED lights up with no problems. Tried this with another USB3 cable (with a 2nd USB connector for power) and the LED works well there too.

b. This pair is then connected to the laptop via a SATA to USB3 connector that I recovered from an old external HDD. This connector is reportedly working fine. The LED blinks well when I connect my old 1TB 2.5" Samsung HDD to it and Windows detects this 1TB disk with no problems - so am assuming the connector is healthy.

2. Tried HFS explorer but nothing happens. HFS cannot detect the SSD. The Disk Management tool on Windows 10 also does not show the SSD - assigning any drive letter is hence out of question.

3. Tried using a MacOS VM (MacOS Mojave 10.14 on VirtualBox installed with an extension pack for support for USB2 & USB3 host controller, Host Webcam, RDP and other fancy stuff) to see if macOS can detect the apple proprietory SSD with but no luck there either.

Any recommendations that I can explore here? Also, is there any way to determine if the SSD itself and the SSD-to-SATA connector are indeed working fine?

 

ASK THE COMMUNITY