Question Major freezes, stuttering and monitor flickering when accessing Windows apps and starting games

Aug 9, 2022
4
0
10
0
Update 08/11/22:
I updated my BIOS and it fixed the freezes and stutters within Windows.

However, running games still have the issue. The extent of freezing depends on the game:

  • Elden Ring - would load me into the game world, but would freeze and crash within a minute or two.
  • Apex Legends - after clicking Continue, the Apex loading logo would freeze and it would lead to a black screen
  • Horizon Chase Turbo - clicking Press Any Key would freeze the game
Tried testing on 2D pixel art games such as Garden Story and Vampire Survivors and they don't have this issue.

Other fixes I tried after updating my BIOS:
  • Rolled back 1 version of NVIDIA GRD Drivers
  • Switched from GRD to latest SD Drivers, with Clean install through the NVIDIA installer
  • Rolled back 1 version of Windows Update
--------------------------------------------------------------------------------------------------------------------------------------------------------------

I'm experiencing frequent issues mentioned above in my new PC. The PC was built last 08/13/2022 with all brand new parts and I was able to use it normally until today (I even got to play 10+ hrs of Elden Ring and 10+ hrs of Apex Legends before this happened).

Initially I thought this was an error with Elden Ring, but now my PC would freeze when running games past their loading screens (the game menu would still run but it would freeze when starting the actual game), it would also stutter when opening/using the Start Menu, and on the login screen when I would press any key to open the password input.

I even tried using the Windows Phone Link app, but it froze, turned off the monitor, then forced the PC to reboot. I was only trying to refresh the Pictures sync in the Windows Phone app.

I recorded these issues on my phone, you can view them here to give a clearer picture of my problem: https://drive.google.com/drive/folders/1Qyh2VjwloZh_O1D8onrTs5Holz2vc6Np?usp=sharing

Full PC Specs
  • OS: Win 10 64-bit
  • BIOS: American Megatrends International, LLC. F13, 08/07/2021
  • CPU: AMD Ryzen 5 5500
  • MOBO: Gigabyte B550M DS3H AC
  • GPU: Gigabyte RTX 2060 6GB
  • PSU: MSI A650GF 80+ Gold
  • RAM: (16x2) 32gb Team Group Dark Za Alpha DDR4 3200
  • Storage Boot: Samsung 980 M.2 NVME SSD 500GB
  • Storage Gen: Samsung 870 QVO SATA SSD 1TB
Note:
  • All drivers updated to the latest versions as this is a newly built PC
  • No overclocking or undervolting done to GPU and/or CPU
  • Not using UPS or AVR
  • Apps running on startup: IDM and Logitech Gaming Software (for my mouse)
  • CPU/GPU Temp (idle): 30-40 C
  • CPU/GPU load (idle): <3% CPU, ~1% GPU
What I've tried so far:
Initially thinking that this was an error with Elden Ring, so the fixes I tried first was for the game:
  • Set Shader Cache Size to "Unlimited" in NVIDIA Control Panel
  • Turned on/off Hardware-accelerated GPU scheduling in Windows Graphics Settings
  • Turned on/off Game Mode in Windows Games Settings
After discovering that the issue affects the whole system, these are the fixes I tried:
  • Clean reinstall of NVIDIA Drivers through the NVIDIA installer
  • Uninstalled NVIDIA Broadcast (as it started causing errors on startup)
  • Restored settings to Default in NVIDIA Control Panel
  • Removed and plugged back in the HDMI cord of my monitor
Consulted my PC builder friends any possible solutions, they suggested I reinstall/reinsert my GPU and RAM then check. They also suggested to reinstall the OS if the first solution failed.
I'm also planning to undervolt my GPU, as I'm thinking this may be an issue with the GPU and PSU. However, before I try any of these I would like to seek advise in other PC building communities like here.

I'll be grateful for any help. Thanks
 
Last edited:

ASK THE COMMUNITY