Major problem with BF3 and 6970 crossfire

Status
Not open for further replies.

Stef1_1

Distinguished
Sep 10, 2009
123
0
18,680
My Rig:

Intel i7 920 @ 4.00ghz
Corsair dominator ram 8gb 1600mhz
7200rpm HDD (soon to be a ssd)
1200w Corsair ATX
Antec 1200
Motherboard = gigabyte ex58 UD5
Graphics card(s)= 6970x2

Now, I am having microstuttering in Bf3 with the latest cap4 for 11.9 and I'm using 11.10 Ref 3 but when I disable crossfire everything is pretty smooth but lower frames, I also disabled UPLS in the registry. I am going insane with this problem I have no idea how to fix it, oh and might I add I have disabled hyperthreading and HPET in the bios, nothing has helped.

Any ideas?

Thanks in advance :cry:
 

neonneophyte

Distinguished
Feb 18, 2010
159
0
18,710
ive heard reports that hyperthreading is causing microstuddering as well, so make sure its off

edit: i should read better. you did.

crossfire really is a driver thing. i would suggest waiting until drivers fix it (and they probably will) and only using one card if its that bothersome. if you disable 4xMSAA on Ultra settings you will see over 60FPS most the time (at least i do, my card is unlocked and oc'd tho, so mileage may vary)
 

viktorbkk

Distinguished
Oct 29, 2011
89
2
18,635


Save yourself the trouble and go nVidia next time :p
 

Stef1_1

Distinguished
Sep 10, 2009
123
0
18,680
The thing is, I see about 75-90fps but the stuttering is crazy. Makes it look like 30fps thus why it's microstuttering.
 

Stef1_1

Distinguished
Sep 10, 2009
123
0
18,680


I disable AA and the microstutter is still there but not that noticeable. I have no idea what to do, if the upcoming driver doesn't resolve this I will have to buy a new pair of cards.
 

Stef1_1

Distinguished
Sep 10, 2009
123
0
18,680
Thanks for the replies guys, ok I'll try with one card and 4xMSAA disabled, I also never completed Crysis 2 because I had insane flickering on the trees so I never botherd to complete it and yeah I've tried vsync lol.
 

Stef1_1

Distinguished
Sep 10, 2009
123
0
18,680
Yup, 11.10 Rev 3. Same thing, I tried reseting my overclock aswell the optimized defaults. Same thing happens, I should be able to max this game out no problem I'm seeing people with a GTX 570 running it on ultra, like I said the most annoying thing is that I see the frames are like 65-90 but it feels like 30. It's strange everything above a 100fps though is really smooth but as soon as it dips to about 90 it just gets choppy. I have also noticed when there is alot of objects in the game (not action) it's when the choppiness happens, because this game is cpu heavy do you think my cpu may be dying?
 

billj214

Distinguished
Jan 27, 2009
253
0
18,810
Well at least you don't have BSOD like others, they have had success disabling Realtek devices and turn off any Gigabyte overclock utility.
I am trying to put together a list of stats from people having issues, over 95% have Gigabyte boards. It could be caused by driver conflict with another device.
 

Stef1_1

Distinguished
Sep 10, 2009
123
0
18,680


Jesus, I'm sort of lucky then, the only thing I get is the system hardlocking when the frostbite 2 engine has a DX error when changing Anti Aliasing in game.

Also that would be awesome to see that list.
 
Status
Not open for further replies.