Major Skyrim issues. 20-30 FPS on all settings.

DudE132

Distinguished
May 28, 2011
178
0
18,680
I just renistalled Skyrim and on all settings, Ultra/High/Medium/Low at 1080p, I am stuck at 20-30 FPS. The game is incredibly choppy and feels horrible. The only things I've done to Skyrim was install one of the popular ENB mods, but even without it it still happens. And make the common changes to the ini.

Phenom 2 x4 BE
GTX 560 TI
4GB RAM

I just tested the arena mode in The Witcher 2 maxed out in 1080p and got 40-50 FPS with absolutely no issues at all and was as smooth as butter. So it can't be my hardware.

Can anyone please help me?
 

nocturnal7x

Distinguished
Dec 2, 2008
277
0
18,810
Kinda sounds like the frames are being limited to 30, I believe this value can be set in the ini.

running any mods? with enough AA the HD texture pack will be too much for your 560.

maybe this is what im thinking of?
http://linearskillz.wordpress.com/2011/11/13/skyrim-pro-tips-that-help-with-mouse-control-and-physics-glitches/
 

popatim

Titan
Moderator
turn off vsync in the game.
Vsync attempts to lock you at 60fps and if it cant maintain that then it drops you to the next mulitplier of 60 which is 30, and if it cant maintain that then it drops you to the next one , you guessed it: 20.

why you cant maintain 60 on low with a 560TI beats me, updated nvidia drivers lately?
 

d3lit3

Distinguished
Sep 25, 2007
103
0
18,680
Yes go into your skyrimprefs.ini and turn off vsync, as well as the mouseacceleration. Also, try settings shadows (and only) to high instead of ultra. And run AA and AF through nVidia control panel and not in-game.

Do you have the latest patch? If The Witcher 2 works fine it must be Skyrim itself. I have a x4 945, 560ti, and 4GB myself and the game plays buttery smooth @50fps even with mods and the major 2K texture packs installed. The patches make a difference.