Malfunctions/problems with new build


Jan 19, 2011
Hi Tom's Hardware community

I recently took advantage of the Black Friday prices and bought some new parts for my existing build. After finishing the new build, I ran into a long series of potentially serious problems.

These are the internal components of my original build:

Gigabyte GA-P67A-UD3 rev. 1.0
Intel i5-2500K Sandy Bridge
EVGA GeForce GTX 570
Western Digital Caviar Black 640GB (WD6402AAEX)
Corsair XMS 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) 1.65 Volts (CMX8GX3M2A1600C9)
Lite-On iHES208-08 BD/DVD Drive
SeaSonic X750 Gold

The new parts I bought are:

ASRock Z77 Extreme4 (replaced P67 motherboard)
Intel 330 Series Solid State Drive (SSDSC2CT180A3K5) (Added as system drive, WDCB is now an auxiliary drive)
Antec Kuhler 620 (to replace stock Intel HSF)
Corsair Carbide 300R (to replace ANTECquated Nine Hundred USB 2.0)**

**Fans are now plugged in to headers on motherboard, instead of directly into the PSU. The BIOS is responsible for controlling these fans.

Moving on, I started having issues with this build as soon as I had installed Windows. The first thing I did was run Windows update while simultaneously installing the chipset drivers from the CD that came with the motherboard. It didn't matter which sequence I did it in, after rebooting to finish the installation I would get the Black Screen of Death (no Windows login screen). I ended up re-installing Windows 3 times before I tried something else. On a side note, every time I reinstalled Windows, Windows would automatically update with 4 updates, which is strange considering the first batch of manually initiated Windows updates was a total of 168 updates, not 4.

Also, sometimes clearing the CMOS would get me a good boot, but afterward it would fail again. There were also times where after the POST, the system wouldn't even load Windows, there was just a black screen with a flashing cursor. In addition to that, I was having more trouble with the BIOS boot menu - sometimes it would show Windows Boot Manager as priority #1, or #3 behind the SSD and optical drive. Obviously, it wouldn't always show the WDCB either. Sometimes it would list the optical drive twice (one AHCI one UEFI). Very confusing.

I then decided to install only the LAN driver from the CD, and NO Windows updates, and I finally got the system stable. I cancelled the automatic Windows update and did the first batch of 168 updates on my own, no problems. The system was still stable. After I continued with driver updates, I eventually got a BSOD. I worked on troubleshooting it for a few hours, and after checking the DUMP file and debugging it, it was evident that there was a driver conflict. The BSOD was IRQL_NOT_LESS_OR_EQUAL, and it was referencing ntoskrnl.exe +71f00, with a stop code of 0x0000000a. WhoCrashed also mentioned something about igdkmd64.sys, which is the Intel HD Graphics 3000 driver.

At this point I reformatted again, installed only the LAN driver and immediately went to work on downloading and installing the updated version (from the web) of every relevant driver and utility that came on the ASRock CD. These include:

-Intel HD Graphics 3000
-Realtek HD Audio
-Broadcom LAN
-Rapid Storage Technology
-Intel ME
-Intel USB 3.0
-ASMedia USB 3.0

I then immediately updated the BIOS through the Internet Flash utility (directly from BIOS). When the computer booted again, I ran SlimDrivers to make sure everything was up-to-date. Next, I starting updated Windows, and partway through the download I installed other programs like Malwarebytes Free Version, Microsoft Security Essentials, Google Chrome, SpeedFan, and other important drivers like the ones for my Logitech Webcam, keyboard, and mouse (which I kept disconnected and used a PS/2 keyboard prior to this, to prevent any possible error). Once all that was done, I shut down the computer, re-inserted my GTX 570 and installed the latest nVidia drivers (306.97). The last thing I did before going to bed was start the next batch of Windows Update (around 170 updates, 2 gigs of data).

When I sat down in front of my computer this morning, it was still on (it wasn't supposed to be). An error message was present, and it said my system was using too much memory. I looked at taskmgr and it was using 7.8 gigs of memory (nearly all of it!). Windows Update still hadn't completed! It was a third of the way through. I was shocked, but after I clicked OK it continued updating, albeit EXTREMELY SLOWLY. I stopped the updates, and then Windows Update told me "Windows can't update important files and services while the system is using them. Save any open files, then restart the computer." Once I restarted the computer, it said "Configuring Windows Updates" before and after restarting. After restarting, it took a very long time to configure said updates. I'm not sure what it was doing during this time, maybe it was downloading and installing the updates that were not yet finished previously??

I then queued up the next batch of updates and it's still downloading and installing extremely slowly. It's also seemingly hanging - Windows Update seems to be getting stuck on one update and the progress bar is not moving at all. When I clicked on Stop Installation it gave me the important files/services messages that it gave me before. I currently have Process Explorer and Windows Task Manager running and I took screenshots. The first four screenshots were taken 30 seconds apart because I had to scroll down so you can see all the processes running. The final two were taken just before I uploaded this (~30 minutes after the first four were taken). You can see the increased memory usage during that time.

I've uninstalled Microsoft Security Essentials, Malwarebytes, and SpeedFan between then and now. SpeedFan wasn't working properly anyway - note the hard drive detection errors in the message window and no RPM reading for the watercooler. That's a question for another thread. Also, does anybody know how to interpret the color coded rows in Process Explorer? I'm at a loss. Lol, flash player just crashed and memory usage went down from 6 GB to 4.5 GB. Not sure what the problem is there (I was listening to a soundtrack music playlist on YouTube). Take note of the high memory usage from Google Chrome, svchost.exe, dwm.exe, IAStorDataMgrSvc.exe, and most importantly TrustedInstaller.exe (in addition to the high CPU usage).

On another side note, I am using memory that runs at 1600 MHz, 9-9-9-24 latency, and 1.65V. When I looked at the BIOS auto settings, it was set for 1066 MHz, 7-7-7-20 latency, and 1.65V. I changed the settings to 1600 MHz, 9-9-9-24 latency, and 1.5V. I'm not sure if this is the culprit, but I know that running at a lower than standard clock speed and latency is bad for the memory, and running at a voltage higher than 1.5V on Sandy Bridge is bad for the processor. I ran a full battery of Memtest86 tests a few months ago, which turned up nothing.






It seems like you are having a pretty crazy problem there my friend. I don't think my computer has used more than 6GB of RAM at any given point.

I actually had a very similar problem with the ASRock Extreme3 Z77. After taking forever to do really nice cable management I booted the computer and got a bluescreen following the Windows logo.

This was expected, as I forgot to re-install Windows.

I re-installed Windows about 3 times, and noticed that my computer was running madly slow. I then installed the Windows updates, which proceeded to take forever.

Then something else happened, which I now forgot, which caused me to just send back the motherboard for a refund.

Then I realized that I did not include the driver CD and manual when I sent it back, but I still got a refund anyway.

I figured that my old motherboard worked, and there was no reason to replace it yet.

This might not be the case for you. As for your problem, I would try to find out what it using so much memory. If you go into the control panel, you can see what is using the most resources.


Jan 19, 2011
Based on what I saw in Resource Monitor and Process Explorer, it's Google Chrome, TrustedInstaller.exe, and several dll's running under svchost.exe (they are dwm.exe, netsvcs, LocalSystemNetworkRestricted, and the Windows Update process wuau something).

I'm hoping it doesn't turn out to be the motherboard, because returning a motherboard is never fun...the problems you experienced with your motherboard are unfortunate, but I'm trying to rule out everything else before RMA'ing the motherboard.

I'm trying to rule out the Corsair memory first. I don't think the modules are bad because I tested them 2 months ago with a full memtest battery, and nothing came up. I am concerned that the ASRock BIOS is doing something fishy with the memory, because when the settings were on auto it had the memory set to 1066 MHz, 7-7-7-20 latency, and 1.65v. The voltage is normal, but the memory should be at 1600 MHz and 9-9-9-24 latency. Another possibility is that by manually setting it to 1.5v to stay within Intel guidelines, I could have caused the problems myself. Perhaps I should reformat again and see if the problem persists after setting the memory back to auto. I'm still waiting for Corsair customer service to get back to me on this one.

I've done several things since my last post, like uninstalling and reinstalling .NET Framework, using Microsoft FixIt on Windows Update (which turned up several problems but says it has repaired it). We shall see if it makes a difference.


Jan 19, 2011
I noticed another pattern, which is not reflected in the screenshots. When looking at Resource Monitor, the number of hard faults per second (while using Windows Update) is at 100, which is the top of the graph in Resource Monitor. Also, for some reason the system will have 2 GB or more memory categorized as "In Use," with 2 GB or more extra memory categorized as "Standby." Weird.

I was getting this error code on one of the updates:
When I ran the FixIt tool for the MSI, I got this: Potential Windows Update Database error detected 0x80070057
I am also getting problems detected and fixed when I run FixIt for Windows Update itself, with additional failure codes like 0x80242008.