Question Massive performance issues with Ryzen 9 5950X

uplink-svk

Distinguished
Hey there,

I recently purchased Asus ROG VIII Formula and gotten 5950X on her. I'm using newest beta BiOS 2402 [tried also previous version 2311 ] and I'm running into massive issues.

When I use BiOS default settings, I can get barely 11K pts [and sometimes going down to 8k] in CPUz multi-thread and 580 - 610 in single-thread. Cinebench R20 is running also very poorly in default settings and that's at ~8500cb for multicore and 550cb for single core. I also ran Geekbench and 3D Mark.

I'm using NH-D15 Chromax Black to cool the monster, and am using 2 x 16GB G.Skill TridentZ Royal CL16 memory running at 3600 MHz [D.O.C.P.]. I tried 4 x 16 GB but that's a complete disaster.

I'm using second PCi-e slot for my VGA [RTX 3090 Strix OC], because first interferes with cooler.

I tried all possible and impossible memory and PBO settings in BiOS and the only time I'm getting "so so" performance, as I should according to benchmarks is when I use Ryzen Master and use Auto OC mode, and in this case I achieve "stock" values in multithread and subpar values in singlethread.

I'm able to get good single thread performance [677 pts in CPUz] in some random settings in BiOS, but than the multithread suffers [11k instead of 12 - 13k].

Any clue on what should I do? I'm totally desperate :/.

I mean I tried so much, cought only a glimpse in this thread of mine. What could be the issue? Memory? Graphcis card in PCi-e port #2? My two MP600 NVMe SSD drives? Should I get 4000 MHz memory?

I'm totally lost here, please advise,

With kind regards

uplink
 

QueueCumber

Distinguished
Dec 20, 2009
37
1
18,535
0
I'm in the same boat as you but on a MSI x570 Godlike. Lower than normal single-core on cinebench 20. CPU score on Time Spy at 11,239. I managed to get it up to 12k at one point, but that's still over 2k lower than what I should be getting.

I am running 4000Mhz memory, so, no that won't solve this issue...

I was having the issue with SLI installed (2x 3090s) and without SLI (so, no, pcie slot is not the issue for you most likely). With 2 RAM modules and with 4 RAM modules. I also played with every setting possible and couldn't find the issue. What's most annoying is a reviewer is using the same setup as me and is getting those much higher scores.

I installed windows several times now. Updated all the essential drivers numerous times. Tried every BIOS iteration and Beta at MSI.

Contemplating flipping the chip and hope B&H gets a better chip for me in December when it ships, or giving up on this last SLI system and returning everything for a refund and flipping the 5950x on ebay. I'm too old for this sh**.
 
Last edited:
Reactions: uplink-svk

uplink-svk

Distinguished
I'm in the same boat as you but on a MSI x570 Godlike. Lower than normal single-core on cinebench 20. CPU score on Time Spy at 11,239. I managed to get it up to 12k at one point, but that's still over 2k lower than what I should be getting.

I am running 4000Mhz memory, so, no that won't solve this issue...

I was having the issue with SLI installed (2x 3090s) and without SLI (so, no, pcie slot is not the issue for you most likely). With 2 RAM modules and with 4 RAM modules. I also played with every setting possible and couldn't find the issue. What's most annoying is a reviewer is using the same setup as me and is getting those much higher scores.

I installed windows several times now. Updated all the essential drivers numerous times. Tried every BIOS iteration and Beta at MSI.

Contemplating flipping the chip and hope B&H gets a better chip for me in December when it ships, or giving up on this last SLI system and returning everything for a refund and flipping the 5950x on ebay. I'm too old for this sh**.
Thx Lord someone reacted, I thought Iwas alone :D. And now for my second worry, do You think it's AGESA code, MSi/Asus FW, or we're having some crappy pieces?

Btw. I've got full performance after heavy OC, but only either multithread, or single thread. I managed to see 679 pts in CPUz ST and 13k in MT. But not in one run :/

Do You think our chips are faulty, or something? Imean there should be like 700 pts in ST and 15k in MT in CPUz.

Regarding Cinebench R20, the most I've seen was some similiar result as in reviews, but not quite it.

I bought Ryujin 360 today and I've bought some mean4299 MHz CL17 memory, will try to run it 4000 MHz and CL16.

What memory are You running my friend? They say that Ryzens are mean to RAM :D

And last but not least. What Windows are You running? 1903, 1909, cancerous 2004 or unknown cancer 20H2? I'm on 20H2. And I'm thinkin' about tryin' 2004, since that was the development version for all mobo manufacturers out there when they were writin' BiOS/UEFi for our boards.

And last but not least, dayum, we're like brothers. My main rig is 10900K running at 5.3 GHz 8c/16t undervolted at 1.3 vCore [up to enhanced by EiST] and 5.1 - 5.2 GHz 10c/20t at Z490 Maximus XII Extreme, also running 64 gigs of Trident Z Royals memory, two Corsair MP600 SSD drives [512 GB and 1TB] and an Asus ROG RTX 3090 Strix OC <3

Yeah, the rig doesn't make much sense now, but it did when it sported Titan.
What is the make/model of your power supply? Did you do a fresh install of Windows, for this upgrade? What are your temps looking like?
Asus ROG Thor 1200 [some mean PSU from Seasonic in Asus ROG clothes], dirty install, though very thorough removal of Intel stuff and installation of AyMD stuff, will do clean together with Ryujin 360 and G.Skill TridentZ 4266 MHz CL17. My temps with Ryzen Master Default are up to 65°C with Ryzen Master Auto OC up to 84°C.

With OC I'm getting ST and MT almost as good as a stock Ryzen in reviews [almost! not quite as good and only in CPUz and Cinebench R20]. But only one at a time, never both. And I never managed to ramp it up correctly in 3D Mark TimeSpy CPU Score :(
 
Last edited:

uplink-svk

Distinguished
Your dirty windows install is quite possibly part of your issue. It could be bios related. I remember Asus had issues with B450 and Ryzen 3000 bios support, when it launched.
I'll make clean one tomorrow, although, I've had the same issue with 10900K and Extreme and I had to resolve it with manual OC. Although, Intel has it's Enhanced Intel Speed Step, AMD has an equivalent, but not working as well with manual OC. Never the mind that one, I'll do clean install with better cooling and symmetric RAM [regarding speed for Infinity Fabric Clock] and will see what's the issue.

I tried two latest BiOS-es, one is final, one is Beta, but I can't try any other, since no other would detect the CPU. I mean it would, but it wouldn't work.

Also my VGA is in second PCi-e slot, running at 8x 4.0 speed, but I'll solve that with Ryujin 360. Noctua'z too phat and is covering the PCi-e slot #1 :/. And I know that AyMD hates VGA placed elsewhere [when it's solo] instead of 1st PCi-e slot, so that may help as well too.

Although, I'm a bit worried that @QueueCumber is havin' a same issue with the same high end mobo from MSi. And tried everything I've tried. I hope that our chips aren't somehow faulty :(.

@logainofhades You think there's any chance, that our silicone is faulty?
 
Last edited:
With OC I'm getting ST and MT almost as good as a stock Ryzen in reviews [almost! not quite as good and only in CPUz and Cinebench R20]. But only one at a time, never both. And I never managed to ramp it up correctly in 3D Mark TimeSpy CPU Score :(
What do you mean with "But only one at a time, never both. " ST and MT or CPUz and CB?
You should only get up to 5Ghz on one single core and only in spikes and all core should be at ~3.7
Running all core higher than that would be overclocking.
Also reviewers might have gotten golden samples.
https://www.anandtech.com/show/16214/amd-zen-3-ryzen-deep-dive-review-5950x-5900x-5800x-and-5700x-tested/8
 

uplink-svk

Distinguished
What do you mean with "But only one at a time, never both. " ST and MT or CPUz and CB?
You should only get up to 5Ghz on one single core and only in spikes and all core should be at ~3.7
Running all core higher than that would be overclocking.
Also reviewers might have gotten golden samples.
https://www.anandtech.com/show/16214/amd-zen-3-ryzen-deep-dive-review-5950x-5900x-5800x-and-5700x-tested/8
It means that I can only set OC settings in BiOS either favouring single thread performance [677 CPUz pts almost 680 CPUz pts], or multithread [slightly above 13000 CPUz pts]. I can never have both.

And not only that. Performance fluctuates from one test to another, undependant from temperature, but from some "black magic" inside the CPU or motherboard :D

I saw 4.5 - 4.6 GHz tops all core perf, and 5.025 - 5.050 GHz on single core, but...this is interesting. When I ramp the CPU above 5 GHz, all performance goes to hell. So the sweet spot is just below 5.0 GHz.

And my friend, if reviewers gotten some samples that run better on stock settings than mine on heavy OC, well, in that case AyMD is a sh*tty company. I mean I've never met with this with Intel CPUs, not once in my life. Au contraire. When they advertise I can get maybe 5.1 GHz all core on 10900K, I'm getting 5.3 GHz 8c/16y and 5.1 - 5.2 GHz 10c/20t on NH-D15 Chromax Black.
There is only one board at this time that allows you to do an all core overclock and still keep the single thread boost.
View: https://youtu.be/3CEFQxsgZ20?t=294
I don't need that. All I want is the stock numbers, all reviewers around the world have. Namely, Geek Bench at 1600 pts single core and 15k multicore, CPUz at 690 pts and 14-15k multicore and Cinebench of 10500 cb for multicore and 640 cb for singlecore.

I don't. I paid for that, exchanged it for my 10900K and now I have lesser performance besides all core performance. Now that is super sh*tty.
 
It means that I can only set OC settings in BiOS either favouring single thread performance [677 CPUz pts almost 680 CPUz pts], or multithread [slightly above 13000 CPUz pts]. I can never have both.
Yeah that's how it's supposed to be, you either have all core O/C or the PBO boost.That's why I linked the video of der8auer, that's the only way to get both.
And my friend, if reviewers gotten some samples that run better on stock settings than mine on heavy OC, well, in that case AyMD is a sh*tty company. I mean I've never met with this with Intel CPUs, not once in my life. Au contraire. When they advertise I can get maybe 5.1 GHz all core on 10900K, I'm getting 5.3 GHz 8c/16y and 5.1 - 5.2 GHz 10c/20t on NH-D15 Chromax Black.
There is always a decent amount of variance, look at silicon lottery to see how many % of 10900k can do that, certified for 5.1 is 21% .
https://siliconlottery.com/pages/statistics
There is always a difference in volts/watt heat and clocks between CPUs.
All I want is the stock numbers, all reviewers around the world have. Namely, Geek Bench at 1600 pts single core and 15k multicore, CPUz at 690 pts and 14-15k multicore and Cinebench of 10500 cb for multicore and 640 cb for singlecore.
Stock always depends on how a reviewer interprets stock.
Anand shows 10,096 for CB MT.
https://www.anandtech.com/show/16214/amd-zen-3-ryzen-deep-dive-review-5950x-5900x-5800x-and-5700x-tested/14
 

uplink-svk

Distinguished
Yeah that's how it's supposed to be, you either have all core O/C or the PBO boost.That's why I linked the video of der8auer, that's the only way to get both.

There is always a decent amount of variance, look at silicon lottery to see how many % of 10900k can do that, certified for 5.1 is 21% .
https://siliconlottery.com/pages/statistics
There is always a difference in volts/watt heat and clocks between CPUs.

Stock always depends on how a reviewer interprets stock.
Anand shows 10,096 for CB MT.
https://www.anandtech.com/show/16214/amd-zen-3-ryzen-deep-dive-review-5950x-5900x-5800x-and-5700x-tested/14
I feel ya man, I feel ya, but:

1. stock is stock, it should be guaranteed, at least to some portion, not having such a big discrepancy, I mean I've always had a great portion of differences in 1000, 2000 and 3000 series, but never so dramatic :/

2. built over two dozens of 10900K PC's, even some crazy iTX machines [got a big love 4 'em :)] and I've had totally consistent results on all of the PC's. I mean 24+ units is a good enough sample for 10900K, or? And I'm known to have an unlucky hand :D

Also, all of the 3900X and 3950X's I've worked with were super consistent, and worked "by the book".

3. Anandtech literally had the highest score in all other benchmarks :/, look at Geekbench, it's eyewatering 15 - 16k in multithread. That's preposterous compared to what I have [up to 13k :/]. I don't think that's margin error by measurement or unit quality. It's a completely different CPU :(
 
Last edited:

uplink-svk

Distinguished
It is rare that a CPU is bad/goes bad, especially a top binned CPU, on a manufacturing node that is in its second generation.
Hey there buddy,

So I've got Ryujin 360 up and running + new two RAM sticks [only 16 gigs though :/] at 4266 MHz, QVL RAM and yes...it's running like 10% better. I'm still not in the reviewers zone, but I'm, damn close.

I just tried CPUz, I'm on 680 single thread, 12008 multithread, and Cinebench R20 I'm on 9800 cb...which is...well, good :).

I'll do clean install tomorrow and will see whether it'll imrprove.

Oh, my my VGA is in the first slot, so maybe that helped too?

P.S.: Thought that Ryujin 360 is all looks and no power, but dayum, he has some life in him. It's not Corsair iCUE H115i RGB Pro XT, EKWB Predator, EKWB Phoenix, nor Swiftech hx360 ['ve had these], but he'll do, he'll definitely do.
 
Last edited:

QueueCumber

Distinguished
Dec 20, 2009
37
1
18,535
0
Sorry I missed the responses here. The forum doesn't send out notifications I guess.

My setup:
5950x (coolermaster 360 rgb aio)
X570 Godlike with beta bios from msi website forum
4x8gb G.skill 3800MHz cl14 RAM (just received these today, amazing modules...)
2x3090s (evga ftw3 ultra)


No CPU problem here anymore, I think. It appears the ballistix 4k cl18 memory at 2k was just not working well for whatever reason (whether ram or bios issue not sure) in my setup. 3800 works amazingly well, especially after finding tight settings.

I switched to g.skill trinity neo z 4x8gb 3800mhz cl14, set the fclk to 1900mhz, tighted up timings a bit, and messed with a bunch of other settings and was getting over 17k on CPU scores in 3DMark Timespy (presently sitting on top 10 scores for timespy and timespy 2x gpu), as well as almost top 10 for extreme.

Time Spy 2xSLI

Time Spy All

Time Spy Extreme

I'm presently the fastest 5950x on 3D Mark!

Down the road maybe I will try 4k mhz again. Not sure I can eek more out of 4k unless they come out with 4k with lower CL...
 

lga1156_ftw

Notable
Feb 25, 2020
1,211
129
1,190
95
Some benchmarkers on youtube disable meltdown and spectre vulnerabilities when they benchmark, you can quicktest , download inspectre (open administrative) disable both meltdown and spectre then after restart pc, try benchmark. I have no idea how this affects AMD processors but for intel there is significant boost. If you want to be safe just enable them back , some leave these permanently disabled like "tech yes city" in youtube. But thats your own call.
 

QueueCumber

Distinguished
Dec 20, 2009
37
1
18,535
0
Some benchmarkers on youtube disable meltdown and spectre vulnerabilities when they benchmark, you can quicktest , download inspectre (open administrative) disable both meltdown and spectre then after restart pc, try benchmark. I have no idea how this affects AMD processors but for intel there is significant boost. If you want to be safe just enable them back , some leave these permanently disabled like "tech yes city" in youtube. But thats your own call.
Neat. I will look into it. I'm not a major benchmarker or anything. I enjoy playing around with it when I upgrade to see what I can pull off, but then time to do some gaming. I want the most I can get from my setups to get FPS in 4k as solid as possible.
 

lga1156_ftw

Notable
Feb 25, 2020
1,211
129
1,190
95
Neat. I will look into it. I'm not a major benchmarker or anything. I enjoy playing around with it when I upgrade to see what I can pull off, but then time to do some gaming. I want the most I can get from my setups to get FPS in 4k as solid as possible.
First , second gen i7 i have seen 10% improvements even with spectre , meltdown off. I heard newer gen its less of a hit.
 

uplink-svk

Distinguished
So, I've done clean install today and I have the very same results :(. I'm tryin' Your memory kit @QueueCumber tomorrow, I'm getting it from one e-shop, but I'm not getting my hopes up. I'm starting to think that Crosshair VIII Formula is really bad. Before I've had Gigabyte X570 Xtreme, but she died after a week of usage [3950X]. Maybe my karma is a bit effed up too :D
 

jtk2515

Distinguished
Nov 30, 2013
629
4
19,165
72
So, I've done clean install today and I have the very same results :(. I'm tryin' Your memory kit @QueueCumber tomorrow, I'm getting it from one e-shop, but I'm not getting my hopes up. I'm starting to think that Crosshair VIII Formula is really bad. Before I've had Gigabyte X570 Xtreme, but she died after a week of usage [3950X]. Maybe my karma is a bit effed up too :D
Are you setting it 1 to 1 with the infinity fabric? (set the fclk to 1800mhz with 3600mhz Ram). All of your sub timings are tight?

Also are your ram sticks duel rank? if so only use 2 sticks. if they are single rank use 4.

Does the benchmark score change if you run it from a cold boot? I am not familiar With your Air cooler and if it can keep it cool so it can boost to 5ghz single core and also stay steady in multi core.
 
Last edited:

uplink-svk

Distinguished
Are you setting it 1 to 1 with the infinity fabric? (set the fclk to 1800mhz with 3600mhz Ram). All of your sub timings are tight?

Also are your ram sticks duel rank? if so only use 2 sticks. if they are single rank use 4.
Not really, I'm using D.O.C.P. Even when I manually type down the D.O.C.P. or JEDEC values, I'm having some serious trouble.

And, when I try to go from 4266 19 19 19 36 and 50 to let's say 4000 18 18 18 34 and 48, bam, my PC won't boot and I need to boot cleanly.

Will You help me out with timing for Your [my future] RAM please? A simple screenshot will suffice from manual timings from BiOS.

Thank You!

With best regards

uplink

P.S.: I don't have air cooler. I have Asete 360mm AiO [Asus ROG Ryujin 360]. I had aircooler at the time of writing that message. I "upgraded" somewhat. I removed everything that could've been an issue. Btw. which Windows version do You use? 1903, 1909, 2004 or 20H2?
 
Last edited:

jtk2515

Distinguished
Nov 30, 2013
629
4
19,165
72
Not really, I'm using D.O.C.P. Even when I manually type down the D.O.C.P. or JEDEC values, I'm having some serious trouble.

And, when I try to go from 4266 19 19 19 36 and 50 to let's say 4000 18 18 18 34 and 48, bam, my PC won't boot and I need to boot cleanly.

Will You help me out with timing for Your [my future] RAM please? A simple screenshot will suffice from manual timings from BiOS.

Thank You!

With best regards

uplink

P.S.: I don't have air cooler. I have Asete 360mm AiO [Asus ROG Ryujin 360]. I had aircooler at the time of writing that message. I "upgraded" somewhat. I removed everything that could've been an issue. Btw. which Windows version do You use? 1903, 1909, 2004 or 20H2?
All the reviews I have seen show worse performance when the memory is not set 1 to 1 with the infinity fabric. That is why everyone is recommending running 3800mhz(1900fclk) with the best sub timming you can get. Amd is working with the motherboard manufacturers now and they say they will help release a update so that 2000 fclk maybe a option.

most people I see are going either samsung b-die 4x8gb and declocking them to 3800mhz and tighting the timing to cl14 or 15. This is the fastest ram option but is also expensive at 250-300$. This option takes around 6-8 hours and may corrupt your OS.

or going either 3200 cl14 or 3600mhz cl16 as their performance is within 3-5% of 3800mhz but only cost around 150$.

If your looking for the fastest easy way just buy 3800mhz ram cl14 4x8gbs sticks. Which is the same ram he bought above.

Can you try running your ram at 3800mhz(1900Fclk) and see if you can get cl16? if not try 3600(1800fclk) and try cl16.

Also whatever you do make sure you running 4 ranks of memory. Either 2 rank 16gb dimms or 4 1 rank 8 or 16 gb dimms.
 
Last edited:

uplink-svk

Distinguished
All the reviews I have seen show worse performance when the memory is not set 1 to 1 with the infinity fabric. That is why everyone is recommending running 3800mhz(1900fclk) with the best sub timming you can get. Amd is working with the motherboard manufacturers now and they say they will help release a update so that 2000 fclk maybe a option.

most people I see are going either b-die 4x8gb and declocking them to 3800mhz and tighting the timing to cl14 or 15. This is the fastest ram option but is also expensive at 250-300$

or going either 3200 cl14 or 3600mhz cl16 as their performance is within 3% of 3800mhz but only cost around 150$.

Can you try running your ram at 3800mhz(1900Fclk) and see if you can get cl16? if not try 3600(1800fclk) and try cl16.
Dood, just like You, it's not about 200 - 300 USD with me, I just want to it work :(. It's my third memory kit, I'm already 400e in a loss :/

I will have Your memory sticks tomorrow [well, today, but I need to sleep at least a bit :D] and than I will run it with default D.O.C.P. and I'll set the Fabric Clock to half the speed, just as You assumed.

Can I keep the RAM at D.O.C.P? You and I we literally have the same CPU, MB and RAM, so I will copy Your settings if You allow me and will let You know.

Or should I run the RAM on some custom timing/settings?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS