MASSIVE Performance Issues

ComputerEden

Reputable
Feb 19, 2015
75
0
4,660
5
Hello,

I bought an i7 4790k, a SSD (crucial), 2x4gb DDR3 1600 (crucial)+ a gtx960(phantom) and now im having problems while gaming. sometimes the games or videos just dont look as fluent as they should (feels like 16-25 fps). with fraps enabled i have always had over atleast 80-140 fps, still it feels like a pentium2 and a s3 playing quake 3 arena. what am i doing wrong, why doesnt this work out ?

it has happend in cs go (dispays near 200 fps atleast), in dirty bomb (displayed 144 fps) and in other games aswell (project cars displayed 60+fps but sometimes it wouldnt feel like it was performing well.) this all started a while ago. is my hardware faulty? there is no indication of any hardware issues. i have only had bluescreen when i tried to overclock my ram too far, but on 1600 or 1867 mhz it runs stable.and no error occurs.
 

ComputerEden

Reputable
Feb 19, 2015
75
0
4,660
5
okay, i will but my internet is quite slow. i will reply here and let you know if that did the trick.
i think that will do it, the last update made it happen maybe.
 

ComputerEden

Reputable
Feb 19, 2015
75
0
4,660
5
the update is finally done, ill play a little bit and edit here.
seems to work a little better. i dont know what it is. maybe system instability.

ill downclock my ram to default and set higher vcore to see if that fixes anything.

looks like its running fine now... i guess.

some games just arent perfect ... (project cars works ok, some texture gliches sometimes or my pitguy is barehanded, hope its the game) but most games work fine with 100++ fps
 

ASK THE COMMUNITY

TRENDING THREADS