Question MB not recognizing M.2 SSD anymore

Aug 12, 2019
1
0
10
0
Hello! I'm looking for your help. Something really weird happened.

I've build a PC about two days ago and everything was running super smooth, here are the specs:

MB: Asus Prime Z370-A
CPU: Intel i7 9700F 3Ghz 8 Core
RAM: Corsair Vengeance LPX 32GB 2x16 DDR4-3200
GPU: MSI Geforce RTX 2070 8GB

I've plugged in an external drive that I use for Graphic Design on my Macbook. I wanted to transfer the files to my PC, but the PC just didn't recognize it. I unplugged it, put it back into the Macbook and decided to upload them on a cloud and then download on the PC. I went for a walk cause that's over 50GB of files that I had to upload, but when I came back something weird happened to my Computer. The fans were spinning, the PC looked like it was running but there was no video. Keyboard and mouse wasn't working too. I restarted it and it went automatically into BIOS not Windows and what I saw was that my only drive which is the M.2 SSD 500GB Samsung Evo 970 is not recognized!

I tried everything. I put the M.2 into a different slot, tried different settings on BIOS.. it just don't recognize it. I remember when I wanted to install Windows 2 days ago the BIOS recognized the M.2 straight away and my Boot USB Toshiba. Now that I've researched that I should have disabled CSM and stuff like that, maybe that's the problem? I tried to change that stuff now but it still don't work. I hoped that I can just install Windows once again, but nope.

The M.2 is fresh and runned 2 days. I wasn't even using the Computer that much, just installed some programs, drivers, you know. No games or anything high performance.

I don't know what to do. Change the M.2 to a new one, maybe I destroyed this M.2 because of the way I installed Windows on it before? Maybe its the motherboard, but very unlikely. Can someone help me please? I don't really know anymore what to do.
 

ASK THE COMMUNITY

TRENDING THREADS