Mechanical Keyboard malfunctioning

velosteraptor

Honorable
Jul 20, 2012
333
0
10,810
18
As there was not a subsection on the forums for keyboards or the like, i am trying this section hoping to get some help.

My keyboard is a Razer Blackwidow ultimate, and it has a few problems with it.

During a gaming session, it stopped working for about 5 seconds, and then it alt+tabbed me out of the game and locked me out of the computer. Upon trying to get back in, i noticed my password wasnt working. after trying it several times, i noticed my "l" key did not work.

I tried another keyboard, and was able to log in to windows. I uninstalled Razer synapse, and redid the firmware for the keyboard, but still no luck.

While doing this, i noticed that when the "w" key is pressed, it produces an "m" on the first press, then nothing.
The "s" key does not work either.


I have so far popped off the offending keys, and sprayed compressed air in the switches.

Nothing so far has worked, and of course the warranty on razer keyboards is only one year, and i have owned it for 1 year and 1 month.

If anyone has any suggestions, please help! it was a good keyboard until now :"(
 

velosteraptor

Honorable
Jul 20, 2012
333
0
10,810
18


I did as you suggested, and when the pc rebooted, the keyboard worked fine for about 10 seconds until the little popped up that stated 'drivers had been installed' then the problems came back. What i ended up doing is downloading the legacy drivers, back before synapse was required. All is well now. Thanks for your help
 

Similar threads


TRENDING THREADS