Question Memok light red, no boot, no post, black screen

May 27, 2020
18
2
15
0
First time build and failure on the first power up.

Asus Z170-ar mobo,
g-skill 3200mhz 2x16gb ram,
core i5 6500k,
650 watt psu.

When I power on, lights come on & fans spin but solid red memok light comes on. I've tried all 4 memory slots, one stick at a time same thing. Held the memok button down, it blinked, then turned solid again. Memory is new. Mobo is used. I think I need a new mobo but not sure. Any thoughts?
 

Vic 40

Polypheme
Ambassador
Thing you can stil try is putting a new battery in the motherboard, keep about 5min. in between so that you did a clear cmos at the same time, see if this helps. A new battery doesn't cost much.
 
May 27, 2020
18
2
15
0
Just bought separate ram ddr4 4gb 2666mhz. Same problem. I'll try cmos battery next.will let you know. Just in case, I have another mobo on the way.
 
May 27, 2020
18
2
15
0
I came across an I5 8500 for $132. I'm told it's compatible, but I'm worried about my ram. G.skill Aegis 2x16gb ddr4 3200MHz. I'm not sure if that's compatible.
 

Vic 40

Polypheme
Ambassador
That will work fine. Only thing wil be that the ram won't work at 3200mhz, but wil work at max 2666 mhz. Is the speed limitation for ram on B360 motherboards.

You could try to see if there are options in the bios to tighten the timings which still would improve performance for the ram abit. Google some ram overclocking guides for this if you want to look into that.
 
Reactions: Toledowizard

Vic 40

Polypheme
Ambassador
You could test with the igp only. Means take a dedicated gpu out and use the motherboard video output.

Maybe one of the updates doesn't go well with the pc.

Can try the options in this link,
Critical process died in Windows 10: 8 ways to fix it
don't use any tool they offer, like the "Restoro Repair Tool". They might look like a nice quickfix, but you don't know what they really do and what they put on your pc.

Start under this "How can I fix the Critical process died error in Windows 10?`.

Don´t think nr8 should be necessary with a clean install. And might even try to do one again.

How did you create the install disk? Did you use the Microsoft way?
Windows 10 usb install tool
 
May 27, 2020
18
2
15
0
That's what I was thinking. Maybe the update didn't go well. i believe it's my gpu cause I had to use the on board hdmi cause my card wasn't giving a signal, despite being new. I'm going to remove it and start over. btw, I downloaded Win 10 from the Microsoft website and burned it to an iso disk. I like dvds a little more than flash drives.
 
May 27, 2020
18
2
15
0
I can officially call myself stupid. My psu was clearly the problem. It's supposed to be 650w but the brand name was Lead Power (which I never heard of) and my pc was flickering before it would restart. I didn't want to believe that was it until I switched out the power supply. Hopefully it'll do better now.
 

ASK THE COMMUNITY

TRENDING THREADS