Memories stuck at 2133 after 7700k CPU upgrade

hknoener

Prominent
May 30, 2017
20
0
520
1
Hi, all.

I've upgraded recently my CPU to an i7-7700k.

I was using before an i3-7100, and an i5-7600k (stock) without issues. My memories as 2x 4GB G.Skill RipJaws 4 DDR4-2400.

They were working at 2400 so far without issues. After changing to the i7, they stay at 2133 and don't go anywhere.

My MB is a MSI B250M Mortar Arctic. I've enabled and disabled XMR, manually set to 2400, nothing worked. It sticks to 2133 and I can't figure out why.

I updated my BIOS, just to make sure. Same result.

Am I missing something?
 

Darkbreeze

Titan
Moderator
I'd pull the CPU and make sure nothing got bent. If it won't go higher than 2133mhz even with XMP profile set, and they did before, then either something is wrong, the CPU cooler is too tight or too tight on one of the corners, or you might want to pull the memory and reseat it.

It also might be worth powering off, pulling the CMOS battery for about three minutes, then put it all back again, go into bios, set optimal default, set XMP and try again.
 

hknoener

Prominent
May 30, 2017
20
0
520
1

Is there anything that should be displaying any odd behavior? Just the memory working a little below the frequency is enough to blame the CPU? It's an honest question, I didn't know a CPU could make it and work normally in every other use.

CMOS reset is a pain, but I will give it a try after your other options.

 

hknoener

Prominent
May 30, 2017
20
0
520
1
Hi, @boju.

I've come to check BIOS many times, you can rest assure it was saved before exiting.

As I said, I was lazy about resetting the CMOS.
 

boju

Champion


Well it's quite possible theres too much heatsink pressure on the cpu as discussed. Usually that would bring other issues but with electronics i suppose anything is possible.

Where/ which program are you using to determine ram speed? Is it possible to upload a picture where you're seeing 2133?

When you change ram speed in bios and go back to bios after a restart it's back to 2133 correct? Another possibility but unlikely is a flat cmos battery. Wouldn't expect it since they last a very long time and your board is quite new but this issue is a weird one so thinking of other possibilities. To check if bios is saving changes, disable Hyperthreading or change boot order and see if it sticks after a shutdown.
 

hknoener

Prominent
May 30, 2017
20
0
520
1
@boju

I can see everywhere the same RAM Speed: BIOS, Windows Task Manager, AIDA64. It's always the same.

Even if it's manually set to 2400, I can see it set in BIOS but the speed itself remains 2133. The settings don't change by themselves in BIOS, but the speed stays the same. Surely is not about BIOS not saving settings.

I can try to loose a notch the cooler, but I remember using the same "force" for the i5-7600k and having no issues. As a side note, i7-7700k is warmer than expected (http://www.tomshardware.com/answers/id-3782819/7700k-higher-expected-temperature-stock-clocks-aio-watercooler.html), but "too tight" didn't even crossed my mind as a possible solution.

 

hknoener

Prominent
May 30, 2017
20
0
520
1
@boju

No, that's not what I've written. BIOS *settings* are set to 2400, but even in BIOS the reported speed is 2133. If I let it auto or manual, it will set itself to 2400, but the speed will not change.
 

Darkbreeze

Titan
Moderator
If the speed is not changing and the setting is staying the same, not changing automatically in the bios, then go back into the bios and in whatever section your memory settings are in, find and turn off the memory fast boot feature. Do not confuse it with the boot process fast boot feature for general hardware POST compliance.

There are generally two fast boot settings. One for the entire hardware partition and one specifically for the memory. I have found many times during memory testing that after configuring memory settings and then booting to Memtest and allowing it to run for several hours of testing that I had wasted my time because after exiting Memtest and going into Windows the memory setting was the same as before the changes I made.

Putting the memory fast boot setting to disabled will stop that. After it has booted at least once successfully after disabling the memory fast boot setting you can then go back into the bios and re-enable it. It has to train and configure the secondary and tertiary memory settings at least once successfully or it will just keep using whatever memory settings were last used successfully until the fast boot feature is disabled for at least one boot process. Then it can be either enabled or set to auto.
 

hknoener

Prominent
May 30, 2017
20
0
520
1
Thanks all for your help.

I have found that the problem was the cooler being too tight. It was not as tight as I have put on i5 just a couple of days ago, but for some reason it was not working properly.

It was just to loose it a bit and turn on the computer, everything was at the right place and frequency.

I will add this to my list. Now I just have to figure out the CPU temps.
 

hknoener

Prominent
May 30, 2017
20
0
520
1
I have a question about my CPU temps (http://www.tomshardware.co.uk/answers/id-3782819/7700k-higher-expected-temperature-stock-clocks-aio-watercooler.html) and it would be pretty helpful to hear some thoughts.
 

ASK THE COMMUNITY

TRENDING THREADS