• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Memory 8GB installed bios sees 4GB

Bugler101

Honorable
Dec 6, 2012
8
0
10,510
0
New Motherboard ASUS M5A78L-M LX PLUS, bios version 1302 windows 7 Ultimate 64 bit, video ATI Radeon HD 5450. I have installed 8gb of memory and bios reports only 4gb, windows sees 8gb with 4gb usable. I have tried all the usual fixes, updated bios, swapped sticks ( reseated ) install 1 stick at a time to no avail. I can not seem to find any memory remapping switches in bios setup, but something is locking out 2nd 4gb. Any suggestions????
 

flexxar

Honorable
Oct 6, 2012
431
0
10,860
33
Make sure your first stick is in socket 1 and the second is in socket 2. They are not right next to each other. You can read the numbers in small print on the board or your motherboard manual will tell you which is which. Should be something like 1, 3, 2, 4. 1 being closest to cpu.
 

flexxar

Honorable
Oct 6, 2012
431
0
10,860
33
I would look in the bios for an option for dual channel memory and play around with that.

You said both sticks work, but are you certain that both sockets work individually? Try each, 1 at a time.

With both sticks in, I would reseat the cmos battery to force a new hardware detection.

Did you check to see if your ram is on the supported hardware list?

 

Scott_D_Bowen

Honorable
Nov 28, 2012
838
0
11,060
38
Windows sees 8gb with 4gb usable.

- Run MSCONFIG and restore it's defaults.
- Windows loads it's own BIOS when it starts, so you may be able to ignore your BIOS's detected memory count.
 

Bugler101

Honorable
Dec 6, 2012
8
0
10,510
0
I have verified that the dimms are correct and both slotys work fine. As I said originally Bios only sees 4gb windows sees 8gb using only 4gb. I reset msconfig to normal and it did not work. I believe the problem is somehow in the bios configuration. I find nothing that leaps out to me that it has to do with memory setup?
 

getochkn

Titan
Moderator



What? No it doesn't.
 

Soda-88

Distinguished
Jun 8, 2011
1,084
0
19,460
75

He said both sticks work individually... they don't work together most likely cause they're running at different volts (1,5v/1,65v) and/or speeds.
 

getochkn

Titan
Moderator


Yes, it could be that but most RAM will switch speeds to the timing of the MB which is usually the lowest speed or default voltage, hell mine is a miss match of 4 different types of sticks, a 4GB, 2GB, 1GB, 1GB and I get all 8GB.

Or just be a picky motherboard/bad design. I remember back in the day, the fun of swapping RAM around and having sticks work fine in 1 system but not the other because 1 system didn't like double sided sticks, etc. They would work 1 at a time, but 2 together wouldn't because of the design of the chip. That's why I pointed that out, just could be a bad design or chipset implemenation.

But the OP didn't specify the brand of each chip and whether they are a matched set or anything, so it could be 2 different types.
 

weaselman

Honorable
Oct 27, 2012
1,148
0
11,360
42
Take both of the sticks of memory out, verify that they are of the same voltage, speed rating, and have the same timings on the labels found on the memory sticks.
Next you want to check what memory slots the board requires you two fit the two memory sicks into.
If one stick is at a lower speed rating, then you will have to manually lower the memory speed in the bios to the lowest setting memory speed.
The bank interleaving option in the bios should be set to Auto not off. As it will cause an error in reading the memory sticks. Make sure the EEC option for the memory is turned off. Make sure the on board graphics chipset of the board is turned off and check the frame buffer size of the memory it is using in the bios, that option uses the system memory so if it is set to 4G then that is why your memory is missing. It is reserved for sole use of the graphics chipset solution of the board. So obviously knock it down or turn it off. If you read the manual it states if you put an ATI card in the Pci-e slot the frame buffer option kicks in meaning it reserves system memory as a frame buffer for the card.


 

Bugler101

Honorable
Dec 6, 2012
8
0
10,510
0
I don't see in the bios any way to set EEC, frame buffer or disable onboard video. I have a matched set of 4gb memory dimms from kingstone and they show via asus site to be fully compatible.
 

weaselman

Honorable
Oct 27, 2012
1,148
0
11,360
42
So if you take a fact windows sees 8Gb, it cannot be using 4gb to run just windows. Something else is reserving a block of memory for its sole use as I said, and if you read the manual it says if you put an Ati card in the system There is a frame buffer option enabled to reserve system memory for the card Doh !
 

Bugler101

Honorable
Dec 6, 2012
8
0
10,510
0
weaselman, please I don't want a fight, but I also don't like to be insulted. I have read the manual, now YOU tell me where to the frame buffer and I will try to do it. I find nothing in the bios that identifies with frame buffer. I know I am not stupid but I sure can't find it. Point the way instead of pointing fingers.
 

ex_bubblehead

Glorious
Moderator
Start on page 2-14 of the manual:

All of this is under the 'Advanced' menu:

Chipset
Northbridge Configuration

DRAM Controller Configuration: Set as indicated

Bank Interleaving <auto>
Node Interleaving <disabled>
Channel Interleaving <auto>
Memory Hole Remapping <Enabled>
Power Down Enable <Enabled>

Internal Graphics: Set as indicated

Primary Video Controller <GFX0>
UMA Frame Buffer Size <32MB> (You have a dedicated video card. You don't need addional framebuffer)
Frame Buffer Location <Above 4G>


Those are the only settings I see that would have an effect.
 

weaselman

Honorable
Oct 27, 2012
1,148
0
11,360
42
Thank ex_bubblehea I did try to explain the reason as to the missing memory. since it would use system memory If enabled. There is something about inserting an Ati card and it using system memory also in a lower section. Or memory adress.
 

Similar threads