Question Memory Defaults to 2133 with no fixes so far, Memory also "hardware reserves 8.1gb" Need Serious help

rjdthree

Reputable
Aug 16, 2018
8
3
4,515
0
Hi, I'm not a super knowledgeable person when it comes to computers but I have a basic understanding so please bear with me.

CPU- AMD Ryzen 5 2600 3.4 GHz 6-Core Processor
mobo- ASRock B450 Pro4 ATX AM4 Motherboard
Memory- G.Skill Ripjaws V 16 GB (2 x 8 GB) DDR4-3000 CL16 Memory

Only 7.9 GB of my ram is avaliable, the rest 8.1 is hardware reserved. Ive tried everything under the sun to try and enable the full ram
I managed to fix this problem once by changing the XMP settings in BIOS to 3000 Ram speed which is the advertised speed of my ram, then my pc gave me the "we ran into problems" prompt not less then 10 seconds after opening Task Manager
my other issue is my ram speed itself, which keeps defaulting to 2133 even after setting it to 3000 through an XMP Profile
My guess is that the problem is related and my speed of ram and 8.1 missing availability is intertwined somehow, please help im not too good with computers and if i was im sure id be able to figure this out, thanks.
 

boju

Titan
Ambassador
Have you tried single stick to see if xmp sticks? Try both individually to troubleshoot xmp and memory reserved. Use 2nd slot from cpu for single. For dual, use the last slot. 1st and 3rd slots shouldn't be used as these aren't the primary slots.

3000 isn't officially supported so try 2933 if 3000 still fails. May need to set 2933 manually if there is no xmp profile for that speed. Input primary timings if you set 2933 manually. See what xmp sets those to if not sure and set them the same. Dram volt to 1.35v.

If cooler is on too tight can cause memory issues. Try slacken it off a little if cooler is screw down design.
 
Hi, I'm not a super knowledgeable person when it comes to computers but I have a basic understanding so please bear with me.

CPU- AMD Ryzen 5 2600 3.4 GHz 6-Core Processor
mobo- ASRock B450 Pro4 ATX AM4 Motherboard
Memory- G.Skill Ripjaws V 16 GB (2 x 8 GB) DDR4-3000 CL16 Memory

Only 7.9 GB of my ram is avaliable, the rest 8.1 is hardware reserved. Ive tried everything under the sun to try and enable the full ram
I managed to fix this problem once by changing the XMP settings in BIOS to 3000 Ram speed which is the advertised speed of my ram, then my pc gave me the "we ran into problems" prompt not less then 10 seconds after opening Task Manager
my other issue is my ram speed itself, which keeps defaulting to 2133 even after setting it to 3000 through an XMP Profile
My guess is that the problem is related and my speed of ram and 8.1 missing availability is intertwined somehow, please help im not too good with computers and if i was im sure id be able to figure this out, thanks.
try follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 12 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • restart the pc to bios, disable AMD fTPM and secure boot if it was turned on by default, save and exit, go to bios again, flash to the latest bios (this one uses the latest agesa 1.2.0.7), then after updating bios go to bios again, then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot. Look up in Control Panel Uninstall a Program, find AMD Chipset Software, if its already version 4.03.03, then you're good to go.

  • Install the latest gpu driver, and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). put ram on slot 2 and 4 (or a2 and b2). Download needed files (highlighted word) before doing step 1, do the step in orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 

rjdthree

Reputable
Aug 16, 2018
8
3
4,515
0
Have you tried single stick to see if xmp sticks? Try both individually to troubleshoot xmp and memory reserved. Use 2nd slot from cpu for single. For dual, use the last slot. 1st and 3rd slots shouldn't be used as these aren't the primary slots.

3000 isn't officially supported so try 2933 if 3000 still fails. May need to set 2933 manually if there is no xmp profile for that speed. Input primary timings if you set 2933 manually. See what xmp sets those to if not sure and set them the same. Dram volt to 1.35v.

If cooler is on too tight can cause memory issues. Try slacken it off a little if cooler is screw down design.
Thank you man, I tried both sticks individually in A2 and they both worked perfect with 3000 speed without compromising GB, then I just put them into A2 and B2 and checked BIOS to turn it back to 3000 and it just worked. I don't know what really changed, maybe me taking them out and back in, possibly with a better connection, but I got it thanks.
 

ASK THE COMMUNITY