• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Memory issues with new X299 build

benr_

Commendable
Jan 22, 2018
3
1
1,515
0
I am having relentless MemTest86 errors on my new build. All new components.

Motherboard: Gigabyte X299X Aorus Master (rev 1.0); BIOS: F3c
CPU: Intel Core i9-10900X
CPU Cooler: H100i RGB Platinum
RAM: G.Skill F4-3600C17Q-64GTZKW, Trident Z, DDR4-3600MHz CL17-19-19-39 1.35V, 64GB (4x16GB)
PSU: Corsair AX1600i (because I will be adding more GPUs when the system is stable)
SSD: NVMe M.2 970 EVO Plus
GPU: EVGA Nvidia GTX 1060 (temporary while building)

The machine went together without issues, and booted and installed Windows without trouble.

BIOS is at all default settings, no overclocks. RAM modules are installed in slots per the motherboard manual.

I ran the machine for a day, and installed some typical software I use, also without trouble. I have rebooted the machine many times without issue. Software is all running well from a user point of view.

I wanted to run some proper burn-in tests before calling it a day, and started with MemTest86 running from USB stick.

Immediately on pass 1 of 4 MemTest86 shows errors, and quickly grows to around 100 errors.

I have tested with and without XMP enabled. I also noticed that the Gigabyte BIOS in default XMP "Profile1" selected "auto" for the RAM voltages, and appeared to be setting them to 1.20V, where the RAM spec is 1.35V. I changed that manually to 1.35V, and it didn't help.

I have checked and rechecked every component and cable connection and seating. And as I mentioned, the machine always boots up fast and appears (from a user perspective) to be working fine.

In a crude effort to diagnose the issue, I have now purchased several replacement components (which I will return when I figure out what is going on).

The MemTest86 errors persists with:
  • Completely different RAM. I bought and tried a different set of G.Skill RAM (slightly different specs, but also 4x16GB).
  • A different copy of the exact same motherboard. I bought a duplicate of the same Gigabyte X299X Aorus Master board, and the same issue persists.
The only time MemTest86 does not report errors is when I use a set of Corsair 2x8GB. Then – with just that 16GB RAM, in just two slots – MemTest86 reports no errors over multiple passes. But long term I'd like my 64GB, and also to know what's happening.

At this point I'm wondering: is it possible I have a bad CPU? It's the only component I haven't changed.

Or am I missing something simple but fundamental in the setup?

I'm not particularly sophisticated when it comes to BIOS settings – I've only built a few machines over the years, and always left most settings at defaults. I don't want to overclock, the machine will be enough for me at stock speeds.

But do I need to change some BIOS settings just to get it stable?

Any advice appreciated. Happy to dig into timings and voltages if anyone thinks that will help.
 

Vic 40

Polypheme
Ambassador
At this point I'm wondering: is it possible I have a bad CPU? It's the only component I haven't changed.
If the cpu has a bad memory controller could it be.

You have any trouble running the pc at all? What does Aida64 do when you stress the ram as well or maybe prime95 blend (version 26.6 seems the best).
 

benr_

Commendable
Jan 22, 2018
3
1
1,515
0
After a lot of testing with different components, it turned out there is a BIOS bug in this X299X motherboard.

More information can be found here: https://www.passmark.com/forum/memtest86/46206-gigabyte-x299x-memtest86-memory-errors

My thanks to PassMark support for all their help in diagnosing the issue.

Happily, Gigabyte support are investigating and already sent through one testing BIOS update. That one didn't fix it yet, but I'm happy they're taking it seriously, and hope to have it fully fixed soon.
 
Reactions: Vic 40

ASK THE COMMUNITY

TRENDING THREADS