Question Memory Not Running At Rated Speed

rcampbell578

Prominent
Mar 14, 2018
4
0
510
0
Hey guys,
So I just finished my new build a couple of days ago and everything seemed to be running fine. However, this morning I decided to go into the BIOS settings and check to make sure my RAM was running at the correct speed.

Upon checking, I saw that it was setting my RAM at 2400mhz and not 3200. I also noticed that the XMP Profile was disabled, so I enabled it which changed my speed to the correct 3200.

When I saved and exited though, my computer would not boot up. I restarted and was able to boot into Windows, but kept getting a blue screen. After many tries, I was finally able to get back into the BIOS and reset everything back. Once it is set back to 2400, everything works fine.

This is frustrating since I paid extra for faster RAM, I'd like to get the speeds this set is rated for. Let me tell you what hardware I'm using:

Processor: Ryzen 7 2700X
Motherboard: Gigabyte Auros B450 Elite
RAM: Ballistix Sport 32GB DDR4-3200 1.36V

Here's the link to the exact set I purchased: https://www.newegg.com/ballistix-32gb-288-pin-ddr4-sdram/p/N82E16820164140

I'm also running Windows 10 Pro 64-bit

I've never had issues in the past, but it seems like this particular motherboard wants to set my RAM to a lower speed and when changed, something doesn't like it.

Is there anything I need to do to make this work correctly? Is this RAM even compatible or should I go with another type?

Any information would be helpful. Everything else is running super smooth, so I'd love to get this one minor thing ironed out.

Thanks for the help!
 

rcampbell578

Prominent
Mar 14, 2018
4
0
510
0
Thanks for the reply. I actually got the problem solved, well sort of. I did do a BIOS update, but that didn't help. So I went back into the BIOS and set the speed lower at 3000 MHz. Once I saved and exited, Windows rebooted fine and everything seems stable. I even ran a benchmark on my PC, and got a nice performance boost with the higher RAM speed, so it seems to have worked.

I was racking my brain trying to figure this out and nothing was working. I guess it's just something in my PC that didn't like the 3200 MHz setting. I'll settle for 3000 MHz though. It solves my problem and prevents potential future hassle of having to swap out my memory and try a different type.

Thanks again.
 

ASK THE COMMUNITY

TRENDING THREADS