Memory problem

Status
Not open for further replies.

folivieri

Distinguished
Jan 28, 2012
13
0
18,510
I have a dell Inspiron 518 desktop / Vista 32bit OS. It has originally a Kingston 2 GB 2 Rx8 PC2-6400U 666-12-E1 memory installled in slot 1. The memory speed in CMOS (BIOS) states 800MHZ for the Kingston 2GB. I wanted to upgrade to 4GB. I purchased 2x 1GB Team Elite PC2-6400 CL5 800MHZ memory and installed correctly but when i checked BIOS the for amount of installed memory it said 4GB but the memory speed only said 667 MHZ. The Kingston 2GB originally alone stated 800MHZ in BIOS, how did it revert back to 667MHZ, when the Kingston 2GB in BIOS stated 800MHZ memory speed. Any advice or recommendation would be greatly appreciated

Thank You
Frank
 
Solution
Yes, BIOS may display the RAM rated speed,

but your mobo supports only Memory Speed up to 667.0 MHz


Memory:
DDR2 PC2-5300, DDR2 PC2-6400
Memory Type: DDR2 PC2-5300, DDR2 PC2-6400, DDR2 (non-ECC)
Maximum Memory: 4GB
Slots: 4
Each memory slot can hold DDR2 PC2-5300, DDR2 PC2-6400 with a maximum of 1GB per slot.*
*Not to exceed manufacturer supported memory.

tlmck

Distinguished
It sounds as the Team Elite may be mislabeled and is actually 667 memory. The machine will default to the lowest speed. One way to check is to take out the Kingston and leave the other two sticks and see what it reads.

edit: either way, it will not make a noticeable difference in performance.
 
Yes, BIOS may display the RAM rated speed,

but your mobo supports only Memory Speed up to 667.0 MHz


Memory:
DDR2 PC2-5300, DDR2 PC2-6400
Memory Type: DDR2 PC2-5300, DDR2 PC2-6400, DDR2 (non-ECC)
Maximum Memory: 4GB
Slots: 4
Each memory slot can hold DDR2 PC2-5300, DDR2 PC2-6400 with a maximum of 1GB per slot.*
*Not to exceed manufacturer supported memory.
 
Solution

folivieri

Distinguished
Jan 28, 2012
13
0
18,510
Hi, I took out the Kingston and just had the 2x 1GB team elite sticks in, checked BIOS and memory speed was 800MHZ. So could it be that the Kingston memory is indeed 667MHZ and not 800MHZ. I tried different install with Kingston and team elite in their respective slots but it always reverted back to 667MHZ with the Kingston installed.

Thanks Frank
 

folivieri

Distinguished
Jan 28, 2012
13
0
18,510


Hi, I took out the Kingston and just had the 2x 1GB team elite sticks in, checked BIOS and memory speed was 800MHZ. So could it be that the Kingston memory is indeed 667MHZ and not 800MHZ. I tried different install with Kingston and team elite in their respective slots but it always reverted back to 667MHZ with the Kingston installed.

Thanks Frank

 

folivieri

Distinguished
Jan 28, 2012
13
0
18,510


Thanks i didnt know that,

Frank
 

tlmck

Distinguished
It could also be that the Team and Kingston do not like each other. That happens less with DDR3 but was still prevalent in DDR2.

Another thing is that some motherboards and/or chipsets will revert to a lower speed when 3 or 4 of the memory slots are populated.
 
Status
Not open for further replies.

TRENDING THREADS