Question Memory Usage Question and Stuttering Issue

Aug 3, 2019
5
0
10
0
Hi,

Recently got done building my first Intel computer (previous were all AMD) and for the most part everything has been working. However I was hoping someone might be able to help me understand some of the memory usage data my task manager is showing and a stuttering issue I have noticed.

So to start with, at times I will see that my memory usage is reaching above 60% and using close to 20 GB of my ram, and in this instance my GPU was also jumping around from 2% to 70% which was a little weird as I wasn't in a game.

I'm personally happy to see it all being used, however I know from my previous build what 16 GB of programs & browsers open is like and I don't have close to that open as seen in the task manager processes list below.

So was wondering if someone had an idea where all that extra ram usage is going or if i just have a memory leak somewhere?

As for my issue, I have noticed stuttering/delays when opening programs for the first time. For instance the below attached images were saved to my desktop and when clicking an image it would take 5-10 secs to load. Once that was finished I could close and open images quickly. However when testing this and opening an image using the photo program my computer actually froze and stuttered for close to 10 secs for the first time ever. After the freeze was resolved and whatever process the computer was doing was killed my ram went back down to 20% and GPU back to 2%. Below pictures were before the freeze.

So was hoping someone has an idea of why this is happening since I found it weird that my new build which is at least twice as powerful as my previous computer is having issues I never had before. I mean since when does opening a photo freeze a computer with an i9 CPU, 2080 GPU and 32 GB of ram?

Appreciate any help or ideas you have.

Build Info:


Memory Usage:


 
Jul 28, 2019
61
1
45
1
Why don't you check what is using 70% of your gpu? Maybe you got some malware in your pc, you 1 of your ssd-s for new windows but keep windows on first one just unplug it. If the fresh install is working there is your problem.
 
Aug 3, 2019
5
0
10
0
All my SSDs are in use and I doubt it is malware considering the computer is only 2 weeks old. Also as seen in the task manager nothing shows as using even 1% of my GPU. So whatever was going on was some hidden process not showing in the task manager.

If nothing else anyone know of a good program to track memory/GPU usage as the task manager seems unable to display what i need?
 
Jul 28, 2019
61
1
45
1
All my SSDs are in use and I doubt it is malware considering the computer is only 2 weeks old. Also as seen in the task manager nothing shows as using even 1% of my GPU. So whatever was going on was some hidden process not showing in the task manager.

If nothing else anyone know of a good program to track memory/GPU usage as the task manager seems unable to display what i need?
Test it in games to see if it's freezing or if you getting some stutters. For gpu and cpu and all other things monitoring install MSI Afterburner you can find tutorial how to set it up. You can use Apex Legends it's free on Origin if you don't have any game. Also check what programs are at your taskmanager startup and turn off those you don't need. It doesn't matter how old is your pc. On your place I would test it on another SSD.
 
Aug 3, 2019
5
0
10
0
So.... the issue might have actually been the program i was testing. Does anyone know if the windows 10 photo app has a memory leak or something? As seen below the photo app is committing 20 GB of memory and i actually saw it show 6 GB active and get my memory to 99%.

 

ASK THE COMMUNITY

TRENDING THREADS