Question Memory_Corruption Error for Modern Warfare?

May 26, 2020
5
0
10
0
Hi all,

I've run into an issue that is driving me insane!
Everytime I load the new Modern Warfare is freezes then CTD with no error message about 30seconds into the main menu. This happens about 9/10 times. I say 9/10 because every so often maybe one chance it lets me load the game and stay in the game, just out of the blue.
I would really appreciate some help with this!
I also want to list the things I've tried:
  1. Clean Boot closing all non-microsoft apps
  2. Increasing Page-Pool size where the game is installed
  3. Removed overclock from CPU,GPU and RAM
  4. Setting the game priority to "Normal" in Task Manager
  5. Clean Install of Microsoft
  6. Reinstalling the game
  7. Reinstalling Battlenet
  8. Running "Repair" game files in Battlenet
  9. Ran MemTest (no errors detected with Ram)
  10. Ran Disc check (No errors with SSD where game is installed)
  11. Ran AV (No viruses detected
  12. Disconnected and closed VPN app
  13. Cleared NV_Cache
  14. Deleted user files within Documents for the game (clearly settings within game)
  15. Ran Verifier (resulted in BSOD on boot so had to turn off via safe-mode)
  16. Running the game as admin and in safe mode
Also my PC Specs:
Mobo - Asrock B450 Steel Legend
CPU - Ryzen 7 3700X
GPU - MSI RTX2070 Gaming Z
RAM - Corsair Pro 3600Mhz 16gb (2x8gb)
PSU - EVGA 650w
Temps go no higher than 60-65degrees while in game.
here is the full crash dump:


Microsoft (R) Windows Debugger Version 10.0.19528.1000 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\sinat\AppData\Local\CrashDumps\ModernWarfare.exe.6328.dmp]
User Mini Dump File: Only registers, stack and portions of memory are available


Path validation summary *
Response Time (ms) Location
Deferred srv*
Symbol search path is: srv*
Executable search path is:
Windows 10 Version 18363 MP (16 procs) Free x64
Product: WinNt, suite: SingleUserTS
18362.1.amd64fre.19h1_release.190318-1202
Machine Name:
Debug session time: Tue May 26 15:26:50.000 2020 (UTC + 1:00)
System Uptime: not available
Process Uptime: 0 days 0:01:05.000
................................................................
................................................................
........
Loading unloaded module list
...........................
This dump file has an exception of interest stored in it.
The stored exception information can be accessed via .ecxr.
(18b8.9dc): Access violation - code c0000005 (first/second chance not available)
For analysis of this file, run !analyze -v
ModernWarfare!swprintf_s+0x8c550:
00007ff6e982a900 488b04c8 mov rax,qword ptr [rax+rcx*8] ds:0000000000000008=????????????????
0:093> !analyze -v
***
  • *
  • Exception Analysis *
  • *
***


KEY_VALUES_STRING: 1

Key : AV.Dereference
Value: NullClassPtr

Key : AV.Fault
Value: Read

Key : Analysis.CPU.Sec
Value: 4

Key : Analysis.DebugAnalysisProvider.CPP
Value: Create: 8007007e on DESKTOP-ATAO7RK

Key : Analysis.DebugData
Value: CreateObject

Key : Analysis.DebugModel
Value: CreateObject

Key : Analysis.Elapsed.Sec
Value: 10

Key : Analysis.Memory.CommitPeak.Mb
Value: 637

Key : Analysis.System
Value: CreateObject

Key : Timeline.Process.Start.DeltaSec
Value: 65


ADDITIONAL_XML: 1

NTGLOBALFLAG: 0

PROCESS_BAM_CURRENT_THROTTLED: 0

PROCESS_BAM_PREVIOUS_THROTTLED: 0

APPLICATION_VERIFIER_FLAGS: 0

CHKIMG_EXTENSION: !chkimg -lo 50 -d !ModernWarfare
7ff6e982a880-7ff6e982a89b 28 bytes - ModernWarfare!swprintf_s+8c4d0
[ 5a bc 1d 8b 08 db 09 2d:65 48 8b 0c 25 58 00 00 ]
7ff6e982a8a0-7ff6e982a8cd 46 bytes - ModernWarfare!swprintf_s+8c4f0 (+0x20)
[ a5 e0 13 8d 4c ed 18 ec:48 ff 25 d5 c3 d8 12 48 ]
7ff6e982a8d0-7ff6e982a8de 15 bytes - ModernWarfare!swprintf_s+8c520 (+0x30)
[ 57 ef 2c df ed f7 73 22:48 63 c1 48 8d 0d 96 c3 ]
7ff6e982a8e0-7ff6e982a90e 47 bytes - ModernWarfare!swprintf_s+8c530 (+0x10)
[ a7 b7 80 13 b6 c2 b0 9e:65 48 8b 14 25 58 00 00 ]
7ff6e982a910-7ff6e982a912 3 bytes - ModernWarfare!swprintf_s+8c560 (+0x30)
[ bc 10 74:48 83 ec ]
7ff6e982a914-7ff6e982a92c 25 bytes - ModernWarfare!swprintf_s+8c564 (+0x04)
[ 5e 76 d2 d4 11 dc 9f 8b:48 8b 0d 6d c7 11 0d 33 ]
7ff6e982a930-7ff6e982a95e 47 bytes - ModernWarfare!swprintf_s+8c580 (+0x1c)
[ 19 ca b5 ef 17 c4 d1 aa:65 48 8b 0c 25 58 00 00 ]
7ff6e982a960-7ff6e982a97e 31 bytes - ModernWarfare!swprintf_s+8c5b0 (+0x30)
[ fb 51 3e 7e 5e 99 1b 69:c6 72 08 e0 9c a0 c6 4e ]
7ff6fe298acc-7ff6fe298af7 44 bytes - ModernWarfare!NvOptimusEnablement+f613c8c
[ 28 62 6b ce 3c bd d1 ee:58 35 e3 09 5a a1 25 cc ]
7ff6fe298af9-7ff6fe298bc1 201 bytes - ModernWarfare!NvOptimusEnablement+f613cb9 (+0x2d)
[ d5 94 74 c7 7b b7 00 2f:4f 10 4a 8b 44 24 58 89 ]
7ff6fe298bca-7ff6fe298bcb 2 bytes - ModernWarfare!NvOptimusEnablement+f613d8a (+0xd1)
[ 25 5d:48 87 ]
489 errors : !ModernWarfare (7ff6e982a880-7ff6fe298bcb)

CONTEXT: (.ecxr)
rax=0000000000000000 rbx=0000000000000031 rcx=0000000000000001
rdx=00000217eb4b15b0 rsi=0000000000000000 rdi=000000b4d6744dc0
rip=00007ff6e982a900 rsp=000000b4d6741d28 rbp=000000b4d6742ed0
r8=0000000000000160 r9=00007ff6fc551f4e r10=0000000000000000
r11=000000b4d6741d60 r12=000000b4d6744dc0 r13=ffffffffffffffff
r14=0000000000000001 r15=00007ff8bd70c760
iopl=0 nv up ei pl nz na po nc
cs=0033 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010204
ModernWarfare!swprintf_s+0x8c550:
00007ff6e982a900 488b04c8 mov rax,qword ptr [rax+rcx*8] ds:0000000000000008=????????????????
Resetting default scope

EXCEPTION_RECORD: (.exr -1)
ExceptionAddress: 00007ff6e982a900 (ModernWarfare!swprintf_s+0x000000000008c550)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 0000000000000000
Parameter[1]: 0000000000000008
Attempt to read from address 0000000000000008

PROCESS_NAME: ModernWarfare.exe

READ_ADDRESS: 0000000000000008

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.

EXCEPTION_CODE_STR: c0000005

EXCEPTION_PARAMETER1: 0000000000000000

EXCEPTION_PARAMETER2: 0000000000000008

ADDITIONAL_DEBUG_TEXT: Followup set based on attribute [Is_ChosenCrashFollowupThread] from Frame:[0] on thread:[PSEUDO_THREAD]

STACK_TEXT:
0000000000000000 0000000000000000 memory_corruption!ModernWarfare+0x0


SYMBOL_NAME: memory_corruption!ModernWarfare

STACK_COMMAND: ** Pseudo Context ** ManagedPseudo ** Value: 2259c7c87e0 ** ; kb

FAILURE_BUCKET_ID: MEMORY_CORRUPTION_LARGE_c0000005_memory_corruption!ModernWarfare

IMAGE_NAME: memory_corruption

MODULE_NAME: memory_corruption

OS_VERSION: 10.0.18362.1

BUILDLAB_STR: 19h1_release

OSPLATFORM_TYPE: x64

OSNAME: Windows 10

FAILURE_ID_HASH: {d8074fd7-f401-8f33-66c3-1a2c6304b600}

Followup: MachineOwner
---------
 
Last edited:

beers

Distinguished
BANNED
Oct 4, 2012
261
51
18,790
8
What system components do you have? Specifically what CPU, RAM and RAM settings are you using? That would generally be conducive to failing hardware, you could test your system against something like Memtest86+ to verify.
 
May 26, 2020
5
0
10
0
What system components do you have? Specifically what CPU, RAM and RAM settings are you using? That would generally be conducive to failing hardware, you could test your system against something like Memtest86+ to verify.
Hi! sorry yeah i realised after i should have put my specs in there along with what i've tried so far, i've updated the thread now at the top, but the answer is Corsair 3600Mhz 16gb Ram, I tried removing the XMP Profile so it ran at stock 2133Mhz but this didnt change anything for.
 
May 26, 2020
5
0
10
0
I'm not saying this will fix your issue but it helped me out on the x570 motherboard. I would crash after a multiplayer round ended almost every time. I had not had issues with the game previously.

I updated my motherboard chipset drivers and the issue has never happened again.

https://www.amd.com/en/support/chipsets/amd-socket-am4/b450
Hey! I double checked my chipset driver, even re-installed it again just in case but unfortunately hasn't sorted it :( i'm losing my mind over the issue.
The game worked fine before they updated it to 1.20 and since then just errors all the time.
 
May 26, 2020
5
0
10
0
No, I don't. I've heard it associated with similar issues, but I'm not convinced.

I am suspecting a driver issue. I'm using driver verifier now, which causes a BSOD loop, FUN! But maybe I'm on to something.
Hmm i wouldnt be too hopeful, I fixed my issue by closing down Argus Monitor as I do use it. Then the devs also posted an official statement saying they are aware of the issue but its not their end and its the games fault, which I do believe as the issue only began for me and others after the most recent updates to the game, since closing Argus I haven't encountered a single issue.
There is something I did though to try isolate the issue and this was before finding out it was Argus.

I created a new local user on my PC, doesnt have to be admin, just a regular user, then login as that user and load the game, it SHOULD load fine with no issues at all. If thats the case then one by one start running/installing the software and apps you use on your other account as usually your apps will be installed just not running. But do it one by one. That way you can at least rid the idea of it being an app interfering with the game.

It seems that their latest patch and updates to their anti-cheat software interred with Argus so I wouldn't put it past me if Argus is not the only software to have the issue. Perhaps you have other monitoring tools or apps running? Worth a shot at least.

For now though ignore the "Memory_Corruption" message, after tons of digging it turns out that Windows just throws that error message out there for literally anything... which doesn't help in the slightest. Because as you can see form my crashdump there's no mention of Argus yet it was the clash.

Also Verifier causing BSOD on boot...mine did too, so don't go down that rabbit hole lol you'll waste your time.
 
May 29, 2020
3
0
10
0
I did end up finding a bad driver with driver verifier-- scpvbus.sys, an old driver for a PS2 usb controller I haven't used in many years. Hard to tell if its related because sometimes MW just runs fine, but the game is running perfectly now.

I do run hard disk sentinel, which does a couple of the same things that argus does, so more threads to pull on should the crashes recur.
 

ASK THE COMMUNITY

TRENDING THREADS