Question Messed up my rig by downgrade from gtx 980ti to gtx 760

Sep 16, 2020
13
0
10
0
I downgraded from gtx 980ti to gtx 760. The 760 does not output a signal through HDMI and I don't know what to do. Currently using Intel onboard graphics to access my rig. I have never ran into a problem like this before, these Nvidia cards have been very reliable since I bought them years ago. I would really appreciate any help or suggestions.

https://pcpartpicker.com/list/Kh4Vtp
 
Last edited:
Sep 16, 2020
13
0
10
0
What was the reason for the downgrade?

Rig/computer hardware specs and OS information?

What monitor(s) are you using?
sold the 980ti. Im using a single Samsung tv as a monitor through HDMI. My OS is windows 10, intel i5 4690k, 16gb of ram, asrock Z87E motherboard. Samsung 850 Evo series 250gb.
 
Last edited:

Ralston18

Titan
Moderator
Connection working:

Asrock Z87E Motherboard [HDMI port] ---- HDMI cable ----> [HDMI port]Samsung TV


GPU =

https://www.asus.com/us/Graphics-Cards/GTX760DC2OC2GD5/

Connection not working:

Asus GTX 760 [HDMI port] ----HDMI cable -----> [HDMI port]Samsung TV

And the sold 980ti worked with the same HDMI cable and Samsung TV - correct? Overclocked?

My first thought is a HDMI cable related problem.

Reference:

https://www.lifewire.com/hdmi-cables-and-connectors-what-you-need-to-know-4685377

Note the link at the end regarding HDMI connection problems.

Second thought being some incompatibility issue between the Asus GPU and the Samsung.

Is Asus GPU Tweak II installed?
 
Reactions: UncleBerry
Sep 16, 2020
13
0
10
0
Connection working:

Asrock Z87E Motherboard [HDMI port] ---- HDMI cable ----> [HDMI port]Samsung TV


GPU =

https://www.asus.com/us/Graphics-Cards/GTX760DC2OC2GD5/

Connection not working:

Asus GTX 760 [HDMI port] ----HDMI cable -----> [HDMI port]Samsung TV

And the sold 980ti worked with the same HDMI cable and Samsung TV - correct? Overclocked?

My first thought is a HDMI cable related problem.

Reference:

https://www.lifewire.com/hdmi-cables-and-connectors-what-you-need-to-know-4685377

Note the link at the end regarding HDMI connection problems.

Second thought being some incompatibility issue between the Asus GPU and the Samsung.

Is Asus GPU Tweak II installed?
Thanks for remidnign about Asus GPU tweak II. I will install that and see how it goes
 
Sep 16, 2020
58
9
45
2
What about the "new" GPU? did you buy it just recently or was it a GPU lying around? if the HDMI cable works with the onboard graphics but not with the GPU i would say thats a GPU issue and that would be the worst case here. Did you make sure you installed it correctly? (dont get me wrong there, its a simple task but idk how handy you are around PCs). Check all drivers, check the GPU on a friends PC if possible. Check if the GPU gets recognized on your PC.
 
Sep 16, 2020
13
0
10
0
What about the "new" GPU? did you buy it just recently or was it a GPU lying around? if the HDMI cable works with the onboard graphics but not with the GPU i would say thats a GPU issue and that would be the worst case here. Did you make sure you installed it correctly? (dont get me wrong there, its a simple task but idk how handy you are around PCs). Check all drivers, check the GPU on a friends PC if possible. Check if the GPU gets recognized on your PC.
The "new" gpu was my old gpu before I had the 980ti. It was in storage for a long time and occasionally used by my friends. I think I installed it correctly.
 
Sep 16, 2020
13
0
10
0
Connection working:

Asrock Z87E Motherboard [HDMI port] ---- HDMI cable ----> [HDMI port]Samsung TV


GPU =

https://www.asus.com/us/Graphics-Cards/GTX760DC2OC2GD5/

Connection not working:

Asus GTX 760 [HDMI port] ----HDMI cable -----> [HDMI port]Samsung TV

And the sold 980ti worked with the same HDMI cable and Samsung TV - correct? Overclocked?

My first thought is a HDMI cable related problem.

Reference:

https://www.lifewire.com/hdmi-cables-and-connectors-what-you-need-to-know-4685377

Note the link at the end regarding HDMI connection problems.

Second thought being some incompatibility issue between the Asus GPU and the Samsung.

Is Asus GPU Tweak II installed?
I cant install Asus GPU tweaker II because the program does not detect my gpu. I will post screenshots.
 
Sep 16, 2020
58
9
45
2
The "new" gpu was my old gpu before I had the 980ti. It was in storage for a long time and occasionally used by my friends. I think I installed it correctly.
Maybe try your other PCI-e slot, like the one below the one youre using. if you are still getting the issue maybe get a 1030ti of amazon for 30 bucks to check if it detects any GPU at all. if it doesnt work, 2nd PCI-e slot. if it works try testing your GPU on a friends Mobo if it doesnt work for him, then its a dead GPU. Maybe clean the PCI-e socket on the GPU with ethanol and try again.
 
Reactions: UncleBerry
Sep 16, 2020
13
0
10
0
Maybe try your other PCI-e slot, like the one below the one youre using. if you are still getting the issue maybe get a 1030ti of amazon for 30 bucks to check if it detects any GPU at all. if it doesnt work, 2nd PCI-e slot. if it works try testing your GPU on a friends Mobo if it doesnt work for him, then its a dead GPU. Maybe clean the PCI-e socket on the GPU with ethanol and try again.
I only have one PCI slot. Sorry for not post my specs in the post. Its a mini itx motherboard.
 
Sep 16, 2020
13
0
10
0
Connection working:

Asrock Z87E Motherboard [HDMI port] ---- HDMI cable ----> [HDMI port]Samsung TV


GPU =

https://www.asus.com/us/Graphics-Cards/GTX760DC2OC2GD5/

Connection not working:

Asus GTX 760 [HDMI port] ----HDMI cable -----> [HDMI port]Samsung TV

And the sold 980ti worked with the same HDMI cable and Samsung TV - correct? Overclocked?

My first thought is a HDMI cable related problem.

Reference:

https://www.lifewire.com/hdmi-cables-and-connectors-what-you-need-to-know-4685377

Note the link at the end regarding HDMI connection problems.

Second thought being some incompatibility issue between the Asus GPU and the Samsung.

Is Asus GPU Tweak II installed?
I tried installing asus gpu tweak II but I get this error.
View: https://imgur.com/a/mASaYYQ
 

Ralston18

Titan
Moderator
Wondering about that reference is to VGA....

Is the following link/website the source for the drivers?

https://www.nvidia.com/Download/index.aspx?lang=en-us

Are you able to access Device Manager and check to see what display drivers are currently installed?

Go to Display adapters, click the ">" arrow.

The should be a list of display adapters shown. Right click each one and select "Properties" then the Driver tab.

My current thought is that the drivers are incorrect or corrupted.

Peek in the Events tab.

Maybe delete/uninstall the drivers for both the 760 and the 980ti being careful to not also take out the iGPU drivers.

No overclocking correct?
 

ASK THE COMMUNITY

TRENDING THREADS