Question Mic disconnects when streaming on discord

Jun 6, 2021
3
0
10
0
Every time I try to stream on discord, my HyperX Quadcast S goes berserk and just keeps disconnecting and reconnecting. I have tried to change all of the discord settings to off and whatnot and nothing has helped. I have also tried changing the usb and nothing. Has anyone else had this problem and solved it?
 

Lutfij

Titan
Moderator
I don't think the issue is with Discord. Might want to check and see what BIOS version you're on at the time of writing for your motherboard. Speaking of which, make and model of said motherboard? What OS version are you on(assuming you're on Windows 10)? You might to see if reinstalling your chipset drivers alleviates the issue. Failing that, uninstall the device(Mic) from Device Manager, delete drivers as well, disconnect from the system, then reboot and then after OS GUI, reconnect the mic to USB port. Lastly, did you try working with the mic using
NGENUITY app from HyperX?
 
Jun 6, 2021
3
0
10
0
I don't think the issue is with Discord. Might want to check and see what BIOS version you're on at the time of writing for your motherboard. Speaking of which, make and model of said motherboard? What OS version are you on(assuming you're on Windows 10)? You might to see if reinstalling your chipset drivers alleviates the issue. Failing that, uninstall the device(Mic) from Device Manager, delete drivers as well, disconnect from the system, then reboot and then after OS GUI, reconnect the mic to USB port. Lastly, did you try working with the mic using
NGENUITY app from HyperX?
My bios version is "American Megatrends International, LLC. A.50, 1/15/2021" Not too sure what that means. Is there another thing that I should be checking? I am on Windows 10. I tried disabling and enabling the mic through device managers a few times. The NGENUITY app does not really help with what is occurring.
 

ASK THE COMMUNITY