Mic playback issue - can't find solution

ngwylie

Distinguished
Feb 23, 2010
46
0
18,530
Hi,

I have a Turtle beach Z6 5.1 surround headset with asus p6t onboard realtek audio and windows 7 home premium.

The headset is new. When I plugged it in and used the mic, I could hear myself talking through the mic through the headphones. I had the problem fixed by downloading newest driver which included the Realtek sound control panel. I fixed the issue through there by muting the "listen to this device" option through there.

I did a system restore. Lost the driver, the problem came back. I've installed the driver again, muted my mic playback again, but the issue is still there. When I DO check the "Listen to this device" box, I hear myself twice (I echo), and when I uncheck "listen to this device" the echo goes away, but I can still hear myself. Could this also be hardware wiring issue?

I've gone through tons and tons of support threads on how to fix the problem so that I no longer hear myself. Any help would be great.

Thanks
-Nick
 

MadCatz900

Distinguished
Nov 20, 2010
231
0
18,690
Not many people seem to be able to help with audio related stuff, its not really an easy thing to fix (or it could be). I think the only way you should be hearing yourself playing back is if you havent muted the mic in your playback volume control (which you have).

Have you tried the front panel port to see if that makes a difference, also mute the "line in" playback volume to see if that helps. This is probably no help at all but i thought id give it a go.
 

ngwylie

Distinguished
Feb 23, 2010
46
0
18,530
Haha yeah I guess so. Yeah I've done everything you've said except trying the front mic port. I don't have a seperate mic and since it's a 5.1 headset it has 4 audio plugs, can't seperate the mic wire to the front