Micro SD card not recognized in card reader, only in USB Adapter

This is kind of a weird one! I have a 8GB micro-SD card that I use in a Panasonic Lumix camera. If I take the card out of the camera and insert it into a micro SD to SD converter card, then into my Sony card reader on my PC, nothing happens. I know the card reader is working, because if I insert a full size SD card in it, the card is readable. I have tried several different micro SD to SD adapters.

If however I insert the micro SD card into a micro SD to USB adapter, it shows up. Using this method, I can see under properties that it is formatted as FAT32.

In device manager, the Sony card reader shows up as 4 different types, as there are 4 different card-reading slots on it. Under the SD card slot, I tried to update drivers, but Windows tells me I have the most current driver. I went to Sony's website to see if I could find a driver directly from them, but it wanted the specific model #, and I will have to take out the card reader to see if it is shown somewhere on it. I am waiting for a new PSU to arrive in a few days, so I will take it out of the Computer then.

In the meantime, has anyone else had this issue with a micro SD card?
 
Thanks for the response. I think that's it. The old full size SD card I was able to use successfully in the card reader was 2GB. It doesn't even specify the class (maybe there was no class 4 or class 10 back then). It is just a MicroCenter "2GB SD Flash Card".

And the card reader is over 10 years old. I took it out of an old computer that I didn't need the SD card reader anymore.

So I guess my best option for transferring photos from the camera to the computer is to use the micro SD to USB adapter, or dig out the "oddball" USB cable that came with the camera.

If I can find newer drivers from Sony for the card reader, perhaps the 2GB limitation has been addressed. (I know I could buy a modern card reader, but transferring photos from the camera is something I do only infrequently).
 

ASK THE COMMUNITY

TRENDING THREADS