Question Micro Stuttering with new GPU

Monsterous

Honorable
Jun 24, 2014
11
0
10,510
0
I recently switched from playing World of Warcraft to playing Star Wars, I was playing WoW on an Nvidia GTX 750 ti with no real issues, going to Star Wars I noticed quite a bit of lag. Thinking it was my old GPU I upgraded to a GTX 1660s Super but after switching I am still experiencing the same micro stutter lag. Changing preferences in Star Wars from "Very Low" graphical setting to "Ultra" has very little impact.

I am not sure where to go from here. When I monitor task manager it shows I am generally at about 50% CPU usage, 50% memory usage and around 25% GPU usage. That seems like nothing is getting overly taxed while playing.

I have attempted to optimize the game settings via the GeForce Experience program as well as playing with a few of the card settings in the control panel after reading some forum posts regarding Star Wars settings. None of these things seemed to fix the issues.

I am running:

Windows 10 64bit
Intel Core i7 870 @2.93GHz
Nvidia GTX 1660s Super
Adata Ultimate SU800 1TB SSD
Asus P7H55 Mobo
16GB DDR3 Ram
700w PSU

I believe all drivers are up to date.

Any help is greatly appreciated!!
 

Monsterous

Honorable
Jun 24, 2014
11
0
10,510
0
I realize the system is older however the system requirements listed for Star Wars: The Old Republic are:

-------------------------
Processor
AMD Athlon 64 X2 Dual-Core 4000+ or better
  • Intel Core 2 Duo 2.0GHz or better
Operating System
  • Windows 7 or later
RAM
  • 3GB RAM
Graphics
Star Wars: The Old Republic requires a video card that has a minimum of 1GB of on-board RAM as well as support for Shader 3.0 or better. Examples include:
  • Intel HD 3000 or better
  • AMD Radeon HD 7450
  • Nvidia GeForce 610
Hard drive space
As SW:TOR is updated frequently, the size of the SW:TOR game folder on your system will increase over time.
DVD-ROM drive
8x speed or better (for installation from disk only) – we recommend using the digital installer.
Internet connection
Since SW:TOR is an MMO, a reliable internet connection is required to play.
---------------------------

Also using the tool at https://www.game-debate.com/games/index.php?g_id=363&game=Star Wars: The Old Republic states that my system is well over the minimum specs although the CPU shows as the bottleneck.

Maybe I wasnt clear enough in which Star Wars game I was trying to play but it would seem that my system should be more than fine to play this game given the game was released 9 years ago making it an (older game)?
 

Monsterous

Honorable
Jun 24, 2014
11
0
10,510
0
Ok, guess the solution still lies in updating mobo and CPU. Seems very strange that my system cant handle this game though. I was hoping there was a simple fix in the settings somewhere rather than spending a bunch of money to upgrade hardware for a 9 year old game that Im well over the system requirements for already....
 

Flayed

Notable
Oct 8, 2019
651
105
840
57
I think in this case the minimum system requirements are enough for the game to run (badly). I remember I used to play star wars years ago it ran ok except in the space station hub place it would struggle drawing all the other players.
 

Monsterous

Honorable
Jun 24, 2014
11
0
10,510
0
Thats actually exactly the problem, the fleet area, 16 man operations (8 man are fine) and 8 man warzones (pvp areas).

All the other situations in the game are no problem for my system.
 

ASK THE COMMUNITY