[SOLVED] Microhpone not working on MSI B450, only recognizes sound when plugged in/out

PrPrO

Distinguished
Feb 9, 2012
13
0
18,510
0
Hello,

I have built a new PC few days ago and when I tried talking to my friends during gaming session, it just won't work.

I have a MSI B450 carbon motherboard with windows 10 on it, installed Nahimic v3 and provided realtek drivers from MSI support page.
Windows doesn't want to recognize any sounds I make when the mic is plugged in (bar doesn't move), it only recognizes short static sound when the mic is plugged in or out. However, microphone is recognized as plugged in and I have tried several microphones, so it's not microphone problem. I have also tried front a rear jacks, but to no avail.

What could possibly be a problem?

Thanks in advance
 
Feb 23, 2019
9
0
10
1
Hey bro i have the same problem. I also build a pc using MSI B450 Tomawak. I install re install drivers and still microphone is actually enable in the sound option (Realtek Hd Audio).
Im using a headset the sounds are working but the microphone is not. But when i try to use a wireless headset then i the transmitter using USB its actually working. I hope someone could help us here
 
Feb 23, 2019
9
0
10
1
Hey bro i have the same problem. I also build a pc using MSI B450 Tomawak. I install re install drivers and still microphone is actually enable in the sound option (Realtek Hd Audio).
Im using a headset the sounds are working but the microphone is not. But when i try to use a wireless headset then i the transmitter using USB its actually working. I hope someone could help us here
 

ASK THE COMMUNITY