Microphone detected, but no input signal.

Oct 27, 2018
I have been using a Yeti Blue microphone with my computer for years. The other day, I plugged in my PS4 controller to play games and immediately my microphone and speakers stopped working. After reading through forums, I found this to be because the controller has both a mic and speaker within it and after plugging in, it became the new default device for both. Everything I read said that changing your default audio and recording devices back should fix this. Well, my speakers now work fine but my mic has still continued to have issues. I have gone through every step I can think of:
- Set as default recording device
- Check levels and mute settings of device
- Ensure drivers are up to date
- Change USB cables, still doesn't work
- Plug in another mic to this computer, it doesn't work either
- Plug this mic into another computer, works fine
- Run the Windows troubleshooter
Still, my problem persists. The mic is being recognized by my system, it just won't receive audio signal. Even when the controller is unplugged and I have deleted it from the Device Manager, I'm still not able to get my mic to work. Has anyone else been able to solve this?