Question Minecraft server not appearing through Eero router

May 16, 2022
6
0
10
0
Hello everyone!

I'm sure this is a common question, and I'm usually able to resolve things like this myself but right now I'm stumped.

I have used the Eero app to port-forward 25565 so my friends can join my Minecraft server. However, it does not appear to be open to the outside internet. canyouseeme.org reports it as closed (Connection timed out).
Running nmap on the gateway reports it as closed, too.
The firewall on the server machine is completely turned off, while I diagnose this.
My IP Address is dynamic, and changes after every restart.

Network topology is as follows:
Server -> Unmanaged Ethernet switch -> Unmanaged Ethernet switch -> Eero Pro 6 -> Adtran Fiber Modem -> ISP


nmap for Eero:
Nmap scan report for 192.168.4.1
Host is up (0.00060s latency).
Not shown: 996 closed tcp ports (reset)
PORT STATE SERVICE
53/tcp open domain
1900/tcp open upnp
3001/tcp open nessus
10001/tcp open scp-config
MAC Address: 98:ED:7E:E0:06:F2 (eero)

nmap for Eero targetting 25565:
Nmap scan report for 192.168.4.1
Host is up (0.0010s latency).

PORT STATE SERVICE
25565/tcp closed minecraft
MAC Address: 98:ED:7E:E0:06:F2 (eero)

Any ideas? I can't get this working.
 
Last edited:
So where are you running the nmap command from. Does the router support that ?

A unmanged switch is simplistic. In effect all ports are connected and it can not block any kind of traffic even if you wanted it to. If one device on the network can can your server all devices can.

So you have eliminated 2 of the common causes. You have a public IP and you know the server responds on the port. All that really is left is the port forwarding. This can be messy becuase it seem all routers are different so you find no generic guides and some routers port forwarding screens can be extremely confusing.
What I would try is to use the DMZ option instead. This is not a long term solution because it opens all ports to the server but it tends to be pretty simple to get configured correctly compared to port forwarding rules.
 
May 16, 2022
6
0
10
0
So where are you running the nmap command from. Does the router support that ?

A unmanged switch is simplistic. In effect all ports are connected and it can not block any kind of traffic even if you wanted it to. If one device on the network can can your server all devices can.

So you have eliminated 2 of the common causes. You have a public IP and you know the server responds on the port. All that really is left is the port forwarding. This can be messy becuase it seem all routers are different so you find no generic guides and some routers port forwarding screens can be extremely confusing.
What I would try is to use the DMZ option instead. This is not a long term solution because it opens all ports to the server but it tends to be pretty simple to get configured correctly compared to port forwarding rules.
Eero definitely supports port forwarding. The app itself gives clear menus when it comes to that. I have correctly port-forwarded it using the app, either by TCP (Which Minecraft natively supports), UDP, and TCP/UDP. Either way, it does not work. The Eero app itself does not support a DMZ, unfortunately.

EDIT: Other Eero users have suggested that another Eero device on the network may be causing a Double NAT. I have since unplugged it, but the results haven't changed.

EDIT 2: I should also note that I tried plugging the fibre modem directly into the switch, but it does not work. The Eero router must do something that resolves the raw data into a usable format. So, I am definitely suspect of the Eero router. Despite it having port-forwarding functionality, it doesn't seem to work.
 
Last edited:
May 16, 2022
6
0
10
0
I will run a test to see if users inside the local network can connect to the server.
EDIT: They can connect to the server. It's only users outside the local network who can't connect.
 
Last edited:
You can't plug the modem into the switch but you could plug the modem directly into the server. The server should then get the IP address on its ethernet port directly. When you connect a switch you have mulitple device on the modem and only 1 will get a IP. Some switches also may claim the IP.

You might have to reboot the modem, not sure about fiber ones but cable modem lock the first mac address they see and don't update it until you power cycle the device.

If the server works directly then you know it is some strange setting in the router. This is a massive pain because they are all different so it could be some silly box you have to click.
'
 
May 16, 2022
6
0
10
0
You can't plug the modem into the switch but you could plug the modem directly into the server. The server should then get the IP address on its ethernet port directly. When you connect a switch you have mulitple device on the modem and only 1 will get a IP. Some switches also may claim the IP.

You might have to reboot the modem, not sure about fiber ones but cable modem lock the first mac address they see and don't update it until you power cycle the device.

If the server works directly then you know it is some strange setting in the router. This is a massive pain because they are all different so it could be some silly box you have to click.
'
Sorry for the late reply, I'll test that now. People online said to restart the Eero after port forwarding, but that didn't work. I'll see if I get better results plugging a laptop running an MC server directly into the modem.

Update: Still isn't working. After connecting my computer directly to the fiber modem, I get no internet access whatsoever.
I ran some other tests using wireless devices, and the Minecraft server itself is accessible to other devices in the network, but still nothing outside of the LAN. Running nmap on my own server reports that 25565 is in fact open, and shows the server brand. 25565 is still closed on the Eero itself. I'll fidget around inside the app and change the ports around to see if for some reason 25565 is blacklisted.
 
Last edited:
May 16, 2022
6
0
10
0
Another update: I still haven't solved the issue but I figured it's worth noting that I do have a dynamic IP address that changes after every restart. I'll add this information to the OP.
 
It is really strange that you can not plug a computer into the modem directly.

If you do ipconfig /all when you are directly plugged into the modem you do not get a ip or you get 169.254.x..x that the machine assigned itself.
The kinda normal process to do this with a cable modem is to unplug the pc from the modem. Boot the modem and wait for it to appear up. Now plug the pc into the modem.
This gets around the locked mac addresses and also the pc assigning itself a IP because the modem took too longer to boot than the pc was willing to wait for a IP.

If this still does not work, did your ISP make you register your router somehow. Maybe they are locking the mac address in their equipment. If this is the case what you can do is find the mac address on the wan interface. You should be able to set the mac address on the ethernet port one the pc to the same one as the router to test.

This is very strange. It almost has to be the eero in some way. Maybe verify the firmware is the latest so it is isn't a bug.

Many people that have gotten to this point on these type of threads do not have actually have a public ip. Verify again that the IP you see inside the router on the wan interface is the same as the one you see on whatsmyip.
 
May 17, 2022
1
0
10
0
Do you have the correct computer being port forwarded? On the computer hosting the server in cmd do "ipconfig". Make sure the IPv4 is the one selected under port forward options. I am unfamiliar with that router, Some you can select the computer, some you must type the ipv4.

Then make sure the correct port is being port forwarded, I know 25565 is default but double check you didn't change this in your server configs. I have before (I did 2565, Simple typo, Took me a couple times looking at it to catch it.).

Also nmap scan I believe should not see your ports, Your router should ignore the scan. You don't want your router talking about to a scan.
 

ASK THE COMMUNITY

TRENDING THREADS