Question Mined GTX 1060 Graphics Card Crashes only in games but not benchmark

Mar 28, 2022
1
0
10
0
Hi there,

I'm new to this community so I may not be able to cover all the details I've missed.

A month ago I've got a used Galax GTX 1060 from a friend and started mining on Hiveos Linux system, everything seems normal until a few days ago, it crashed due to cuda error: "The launch timed out and was terminated" (code:6) from NBMiner.
I tried rebooting but still the same error happened every 3minutes it had booted up, then I removed the gpu and the problem was solved for the rig. Later, I installed the gpu in my normal windows rig, my specs are followed:

Processor: AMD Ryzen 7 5800X 8-Core Processor, 3800 Mhz, 8 Core(s), 16 Logical Processor(s)
Motherboard: MSI B550 GAMING EDGE ATX
GPU: Nvidia GTX 1060 6GB
RAM: Corsair 16GB 3200MHz DDR4 (x2)
PSU: ASUS ROG STRIX 750W GOLD PSU

It booted up surprisingly without major issues, yet until I tried booting up Dead by Daylight on my device, the game started running for a minute then the screen froze while the audio was playing, shorty after the whole game crashed.

After I tried booting up some other games like Minecraft, Roblox and Euro Truck Simulator 2.
Minecraft and Euro Truck Simulator 2 were able to boot without problem but the game Roblox got the same result.

Later I have found multiple forums on the internet and tried the following fixes:
  • Uninstalling and reinstalling Nvidia GPU driver
  • Install Nvidia CUDA driver
  • Underclocking my GPU on MSI Afterburner
  • Checking on GPU-Z if GPU not detected (It appeared to be normal)
When everything didn't work out, I reinstalled windows. However, the problem still remained after reinstalling (or even worsening), I got Wallpaper Engine on my device it used to work probably and now it just wouldn't boot probably.

Then, I changed my focus on hardware and tried several fixes:
  • Replacing 2 Corsair ram with another spare 2 Corsair ram (also underclocking which didn't work)
  • Replacing my GPU with my old Rx 580 (it worked probably but after swapping back the problem remained)
When I thought all hope was lost and tried benchmarking, the funny part is the gpu was able to run different benchmarks without graphics glitches or freezes. Now I am really confused, I could figure out it must be something wrong with the cuda,
but it seems to be a rare case for both the gaming and mining community. It even reaches the professional server-level field. As an ordinary miner and gamer, it seems out of my reach for solving. Now the gpu was used for basic uses.
If anyone with adequate knowledge about this problem, please help, I'm willing to post anything needed.

Thanks,

T
 

ASK THE COMMUNITY