Minimum and maximum processor power state option gone after windows update.

Chaitanyamd

Prominent
May 7, 2017
28
0
530
0
I updates my windows 7 recently and i noticed the option in processor power mannagement regarding the minimum and maximum state is not available. I am not able to play any games which i was able to earlier i need help.
Thank you.
 


Windows 10 is set to 'Balanced' power plan by default. Performance will increase as needed to save power.
You could either change the power plans to 'High performance' or create a power plan.
By the way selecting 'High performance ' won't increase gaming performance and just wastes power and generate heat.

Check the task manager and see if any program is hogging your system affecting performance.

 

k1114

Titan
Moderator
They did not remove those settings. Those settings should not make games unplayable with default settings. Was this a windows update or did you change windows version? What are your specs? What games are you trying to play?
 

Chaitanyamd

Prominent
May 7, 2017
28
0
530
0


I run windows 7 and i tried creating a power plan but still i couldnt find the option to set maximum processor power.
 

Chaitanyamd

Prominent
May 7, 2017
28
0
530
0


My computer heats up and is shut down due to temperature that's why I can't play rise of tomb raider and all at ultra setting which I was able to play earlier.
And I updated windows 7 and did not change the version.
 


Do you see the link 'Show additional plans' when you access 'Power options?
 

Chaitanyamd

Prominent
May 7, 2017
28
0
530
0


They are not there I checked.
 

Chaitanyamd

Prominent
May 7, 2017
28
0
530
0


can you tell me how to share the screenshot?
 

k1114

Titan
Moderator
The settings will be unavailable if virtualization is on. You can turn it off in bios and/or disable hyper v in windows features. Control Panel > Programs > Programs and Features > Turn Windows features on or off, disable Hyper-V and reboot. There is also a way to add it back by editing the registry if this doesn't work. I guess something in the update messed with settings. I've seen that a few times.
 

Chaitanyamd

Prominent
May 7, 2017
28
0
530
0


https://imgur.com/a/vbBeeSF
Can you tell me what exactly to do?
 


You do not have the Hyper-V feature installed
I have 'Virtualization' enabled in BIOS and that does not affect 'Power Management' plans and options.
I suggest you create a power plan with the settings you need.
 

k1114

Titan
Moderator
Hyper-v isn't something you'd have to install and not all cpus have vt-d so enabling it in bios may not remove it. Creating a power plan is pointless because he doesn't have the setting showing.

You can try to edit the registry to add them. This gives easy download links to edit the registry for you. https://www.eightforums.com/threads/power-options-add-or-remove-min-max-processor-state.51027/
 

Similar threads


ASK THE COMMUNITY