Info Mining software not detecting GPU(s) possible solution

Oct 18, 2019
1
0
10
0
Hey all,
Been using these forums for a lot of tips lately, so I figured I'd post one myself.

Recently had trouble while mining with 5 GPUs. Was running great, then started throwing errors. The miners were not detecting them. I spent days reading and trying everything I could, still they were unable to be detected.
Checked BIOS, Integrated graphics, drivers (ran DDU and tried several driver sets), checked risers, tried multiple miners, checked OpenCL, everything I could think of and anything anyone suggested. Reset BIOS, pixel patcher, everything. Still, same result. I was sure it had to do with a windows update that snuck by me or something stupid.

Around the time of the errors, I was getting annoyed that my AV (Avast) kept blocking the miners. Even with exceptions out the wazoo, Avast didn't care, it would reset the exceptions and block everything. Finally got annoyed an disabled my shields. Didn't matter, they still kept removing my miners. I started getting the feeling that the AV messed up the mining apps.

THE FIX: I believe this was a double whammy, sneaky windows update which messed up my drivers, and I believe Avast somehow corrupted my mining files. After removing all cards, reinstalling AMD software, totally uninstalling Avast, deleting all of my miners and reinstalling, Tried the first card, BINGO. Shut down, plug in the rest, fire up the miner and BINGO. All 6 cards hashing away to their hearts delight as if nothing had ever happened. Also, I managed to get everything back online before resorting to CMOS or reinstalling Windows 10 (yay!)

The lesson: There's usually no easy fix. Look at EVERYTHING. I spent 3 days looking at my drivers before I stopped to think about my AV and possibly corrupted files.
(I know, don't run AV on a rig, but to be fair, it was functioning just fine with AV running so it didn't occur to me as a possible issue)

For reference:
ASRock H110 BTC Pro+
Windows 10 64bit
MintCell risers
1-MSI RX570 4gb
1-MSI RX570 8gb
4- MSI RX580 8gb
All BIOS Modded
Clocking controlled with Afterburner
AMD Adrenaline Software

I hope there's at least one person that this helps and saves a lot of time and frustration
 

ASK THE COMMUNITY

TRENDING THREADS