[SOLVED] missing cable on the psu 4+4 how improtant is that

Mar 10, 2019
5
0
10
0
Im having a bit of an issue,
i got an asrock x470 taichi motherboard that comes with 8 and 4 pins for cpu EPS or so

i got a Antec 1300W PLATONUM hcp psu, but for some reason( 2nd hand) even thouhg i have lots of cables im missing the 8 pins> 4+4 eps12v cable
the 8>8 pins is connected and everything is working as it is, im using half custom loop with radiator,
2700x
x470 taichi
1080ti zotac mini
ssd+hdd
32 gb ram 3266

question is, is this cable extremly important in the situation im at, and how can i get one to connect and increase my computers overall performance stability or what not.

thanks so much guys hope theres something to do :X
 

Dark Lord of Tech

темный лорд технологий
Moderator
Aug 18, 2009
126,119
1,161
167,090
24,929
It should run fine with just the 8 pin , but if you want to OC and receive the best performance from the board , you will need both connected.

Additional cable has to come from Antec , for that model. They aren't interchangeable.
 

Dark Lord of Tech

темный лорд технологий
Moderator
Aug 18, 2009
126,119
1,161
167,090
24,929
It should run fine with just the 8 pin , but if you want to OC and receive the best performance from the board , you will need both connected.

Additional cable has to come from Antec , for that model. They aren't interchangeable.
 
Mar 10, 2019
5
0
10
0
It should run fine with just the 8 pin , but if you want to OC and receive the best performance from the board , you will need both connected.

Additional cable has to come from Antec , for that model. They aren't interchangeable.
thanks for the reply, is it possible to buy just this 1 cable from them? and if so how
 

ASK THE COMMUNITY

TRENDING THREADS