Feb 10, 2020
5
0
10
0
Hey guys, so I have a Sapphire Radeon RX 570 ITX 4GB and i took it off to clean some of the dust from the fan. When i put it back, the buzzer made 1 long and 3 short beeps and the display had the NO SIGNAL message. I tried taking off the RAM, cleaning everything, taking the power cord out and putting it back but nothing happened. Also tried removing the CMOS battery and everything you can think. The HDMI cable is indeed plugged into the GPU.
I took it off again and I think that there's a transisitor or capacitor missing in the PCB, I don't really know.
The GPU fan sometimes start to spin and the PC boots, but after like 5 minutes after login into windows, it'll turn off again and the NO SIGNAL comes back.
Can anyone help to see if the component is indeed missing and if it is, whats the type of it? Also, do you guys think if thats the case, the warranty is voided? Any help is appreciated.

Pic of the PCB View: https://imgur.com/a/f5CmZ9V


My setup is:
AMD Ryzen 5 1600AF Stock
Mobo GIGABYTE AB350M-DS3H V2
RX 570 4GB Sapphire ITX - Stock (4 months since I've bought it)
4x4GB RAM Crucial Ballistix Sport OC'ed to 3000mhz
PSU EVGA 400W
SSD Kingston 120GB
HDD 1TB Western Digital
 

jay32267

Glorious
Are you talking about what looks circled in red?
If so...being there doesn't seem to be any damage around it...I think that might be intentional. Sometimes they design circuit boards to have optional components...that don't get added in certain cases.
 
Last edited:
Reactions: nightcrawler375
Feb 10, 2020
5
0
10
0
Yes, its the spot circled. Im worried about that spot because I saw a video on youtube showing the PCB of the same GPU, and it definitely looks like there should be a component in that spot, take a look View: https://imgur.com/a/N7ez1Re

Are you talking about what looks circled in red?
If so...being there doesn't seem to be any damage around it...I think that might be intentional. Sometimes they design circuit boards to have optional components...that don't get added in certain cases.
 

jay32267

Glorious
Yes, its the spot circled. Im worried about that spot because I saw a video on youtube showing the PCB of the same GPU, and it definitely looks like there should be a component in that spot, take a look View: https://imgur.com/a/N7ez1Re
I've zoomed in on both pics and I'm still leaning on that it's intentional.
It doesn't look like (to me) that a component was pulled off that board.
I would expect it to look different.
I would expect more evidence.
Also....it looks like there might be more places on that board where components were intentionally not put.
 

ASK THE COMMUNITY