• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Missing Direct3D Device?

Jun 16, 2020
2
0
10
0
Hi everyone!
I've been having this weird issue with my graphics driver, and I can't tell what the issue could actually be.
Whenever I boot any game, it either doesn't open or it throws some generic Direct3D error.

Booting COD5, I get "DirectX has encountered an unrecoverable error"
View: https://imgur.com/KhY2kCz


Booting Terraria, I get "Could not find a Direct3D device that supports the XNA Framework" but then the game will indeed open.
View: https://imgur.com/MS4Fw4h


I can't tell what the issue could be-- this happened before but after forcing some Windows updates, it fixed the issue.
Except now, whenever I check for updates, there are none for me to install.

Opening dxdiag doesn't have any issues, in fact all the information seems as complete as it could be. Could this be an indication that it's NOT my DirectX?
https://pastebin.com/VHdEg1pk

Does anyone have experience with Windows and graphics drivers giving you the middle finger like this? I can't determine what I can do to fix it.

I've tried:

Installing DirectX9 (Told it's already up to date)
Installing DirectX12 (Same as before)
Windows Updates (Fixed it before, no more updates yet though)
Updating Graphics Drivers (Told they were up to date)
Machine restart (I'm going to try this immediately after posting)

I want to avoid registry changes but honestly I might have to make them anyway.
Is there a way to just uninstall and reinstall DirectX en masse?
 
Jun 16, 2020
2
0
10
0
I'm so mad at myself for not trying sfc /scannow
Meanwhile though, I did actually fix the issue!

I followed [question site link removed]this guide and reinstalled the .NET Framework, and now everything boots again.

Except I didn't have 4.6, everything listed was for 4.8 but the steps still worked. Additionally, I noticed that ASP.NET 4.8 was unchecked by default, so after I uninstalled everything I checked it just in case.
 

ASK THE COMMUNITY

TRENDING THREADS